aboutsummaryrefslogtreecommitdiffstats
path: root/main/ntfs-3g
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-07-24 21:17:36 -0300
committerJakub Jirutka <jakub@jirutka.cz>2017-07-28 22:47:17 +0200
commit4407fdc63ef3d89d0fef9c24719b2f7df24b5b04 (patch)
tree9ad9935091070bcb5b6cb77027b5e062925063e9 /main/ntfs-3g
parent5fa7d23873d9a25a8e394ee4c742fe7cbde72db0 (diff)
downloadaports-4407fdc63ef3d89d0fef9c24719b2f7df24b5b04.tar.bz2
aports-4407fdc63ef3d89d0fef9c24719b2f7df24b5b04.tar.xz
main/ntfs-3g: add symlink to /sbin/mount.ntfs and modernize abuild
Diffstat (limited to 'main/ntfs-3g')
-rw-r--r--main/ntfs-3g/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/main/ntfs-3g/APKBUILD b/main/ntfs-3g/APKBUILD
index 9f77bfb789..9f63527fe1 100644
--- a/main/ntfs-3g/APKBUILD
+++ b/main/ntfs-3g/APKBUILD
@@ -4,12 +4,11 @@
pkgname=ntfs-3g
_pkgreal=ntfs-3g_ntfsprogs
pkgver=2017.3.23
-pkgrel=0
+pkgrel=1
pkgdesc="Stable, full-featured, read-write NTFS"
url="http://www.tuxera.com/community/ntfs-3g-download/"
arch="all"
license="GPL"
-depends=
makedepends="attr-dev util-linux-dev linux-headers"
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs $pkgname-progs"
source="http://tuxera.com/opensource/$_pkgreal-$pkgver.tgz"
@@ -23,20 +22,22 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- || return 1
- make || return 1
+ --infodir=/usr/share/info
+ make
}
package() {
pkgdesc="$pkgdesc (driver)"
+
cd "$builddir"
mkdir -p "$pkgdir"/lib
- make -j1 DESTDIR="$pkgdir" LDCONFIG=: install || return 1
+ make -j1 DESTDIR="$pkgdir" LDCONFIG=: install
+ ln -s /bin/ntfs-3g "$pkgdir"/sbin/mount.ntfs
}
progs() {
pkgdesc="$pkgdesc (utilities)"
+
mkdir -p "$subpkgdir"/sbin
mv "$pkgdir"/usr "$pkgdir"/lib "$subpkgdir"/
mv "$pkgdir"/sbin/mkfs.ntfs "$subpkgdir"/sbin