aboutsummaryrefslogtreecommitdiffstats
path: root/main/oath-toolkit/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-02-25 20:17:52 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-02-25 20:20:22 +0100
commit41749f3500dadfa1aaf6870a2d9d23c9c34cc059 (patch)
tree43f5ff5e728d3e608b44405bd92fe2841fcbea0a /main/oath-toolkit/APKBUILD
parent452f4d932de84a246ccfd26af66f70680abfe586 (diff)
downloadaports-41749f3500dadfa1aaf6870a2d9d23c9c34cc059.tar.bz2
aports-41749f3500dadfa1aaf6870a2d9d23c9c34cc059.tar.xz
main/oath-toolkit: unset dependencies for liboath and libpskc
These two subpackages only ship shared libraries. They should not depend on perl, diffutils, and cvs but without this change they do as they inherit depends from the origin packages.
Diffstat (limited to 'main/oath-toolkit/APKBUILD')
-rw-r--r--main/oath-toolkit/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/main/oath-toolkit/APKBUILD b/main/oath-toolkit/APKBUILD
index e08966707f..e14d1a402e 100644
--- a/main/oath-toolkit/APKBUILD
+++ b/main/oath-toolkit/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=oath-toolkit
pkgver=2.6.2
-pkgrel=0
+pkgrel=1
pkgdesc="OATH Toolkit One-time password components"
url="http://www.nongnu.org/oath-toolkit/index.html"
arch="all"
@@ -32,6 +32,7 @@ package() {
}
liboath() {
+ depends=""
pkgdesc="A shared and static C library for OATH handling."
license="LGPL-2.1-or-later"
mkdir -p "$subpkgdir"/usr/lib
@@ -39,14 +40,13 @@ liboath() {
}
libpskc() {
+ depends=""
pkgdesc="Library for Portable Symmetric Key Container"
license="LGPL-2.1-or-later"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/libpskc.so* "$subpkgdir"/usr/lib
}
-
-
oathtool() {
depends="oath-toolkit-liboath"
pkgdesc="A command line tool for generating and validating OTPs."
@@ -63,6 +63,5 @@ pam_oath() {
mv "$pkgdir"/usr/lib/security/pam_oath.so "$subpkgdir"/lib/security
}
-
sha512sums="201a702a05a2e9fb3a66d04750e1a34e293342126caf02c344954a0d9fd0daafe73ca7f1fe273be129ae555a29b82b72fa2b4770ea2ad10711924e1926ec2cfb oath-toolkit-2.6.2.tar.gz
dda606ee9c32075f2268af76394ac886da419ed42e34a45bb528ff26e39faede420ec7201dc32308d9cbfbc253d27a5d603e7bb6eaffc96a88a6bd9b2b3c54d9 oath-toolkit-2.6.2-gcc7.patch"