aboutsummaryrefslogtreecommitdiffstats
path: root/main/oidentd
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-16 18:52:00 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-16 18:52:00 +0000
commitced1e02903a233c6ca2a36e816cea9fd6946f0ed (patch)
tree17f52ace253ef6a4baaf0d2b81cba0aaeaee6ee9 /main/oidentd
parent8bd4249e988a560cb63b28238f4ed10f46ee9a23 (diff)
downloadaports-ced1e02903a233c6ca2a36e816cea9fd6946f0ed.tar.bz2
aports-ced1e02903a233c6ca2a36e816cea9fd6946f0ed.tar.xz
[various]: update config.sub, and update apkbuild
Diffstat (limited to 'main/oidentd')
-rw-r--r--main/oidentd/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/main/oidentd/APKBUILD b/main/oidentd/APKBUILD
index b16a23344c..cace1bd24c 100644
--- a/main/oidentd/APKBUILD
+++ b/main/oidentd/APKBUILD
@@ -15,9 +15,14 @@ oidentd.conf
oidentd.initd
oidentd.confd"
-build() {
- cd "$srcdir/$pkgname-$pkgver"
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+build() {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,6 +32,10 @@ build() {
--infodir=/usr/share/info \
|| return 1
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
install -D -m755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -D -m644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname