aboutsummaryrefslogtreecommitdiffstats
path: root/main/open-vm-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-02 15:54:34 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-02 15:55:51 +0200
commit96ca18de5be1e6116e4ef0fe6bc8c4ff452f4f41 (patch)
treeaacef3cce922a5f9fa8a23eaccb8ac375813881c /main/open-vm-tools
parenteec2f1c7b69e668c82a014c4454c24de18c5cd68 (diff)
downloadaports-96ca18de5be1e6116e4ef0fe6bc8c4ff452f4f41.tar.bz2
aports-96ca18de5be1e6116e4ef0fe6bc8c4ff452f4f41.tar.xz
main/open-vm-tools: recognize alpine linux
ref #1221
Diffstat (limited to 'main/open-vm-tools')
-rw-r--r--main/open-vm-tools/0001-lib-misc-Recognize-Alpine-Linux.patch46
-rw-r--r--main/open-vm-tools/APKBUILD4
2 files changed, 49 insertions, 1 deletions
diff --git a/main/open-vm-tools/0001-lib-misc-Recognize-Alpine-Linux.patch b/main/open-vm-tools/0001-lib-misc-Recognize-Alpine-Linux.patch
new file mode 100644
index 0000000000..b713137126
--- /dev/null
+++ b/main/open-vm-tools/0001-lib-misc-Recognize-Alpine-Linux.patch
@@ -0,0 +1,46 @@
+From 70438337a96f53019bfb3b5b928d9a9ab8067d64 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 2 Jul 2012 15:48:35 +0200
+Subject: [PATCH] lib/misc: Recognize Alpine Linux
+
+---
+ lib/include/guest_os.h | 1 +
+ lib/misc/hostinfoPosix.c | 3 +++
+ 2 files changed, 4 insertions(+)
+
+diff --git a/lib/include/guest_os.h b/open-vm-tools/lib/include/guest_os.h
+index ffced6d..49f30eb 100644
+--- a/lib/include/guest_os.h
++++ b/lib/include/guest_os.h
+@@ -152,6 +152,7 @@ typedef enum GuestOSFamilyType {
+ #define STR_OS_ESX_5 "VMware ESX 5"
+
+ /* Linux */
++#define STR_OS_ALPINE "Alpine"
+ #define STR_OS_ANNVIX "Annvix"
+ #define STR_OS_ARCH "Arch"
+ #define STR_OS_ARKLINUX "Arklinux"
+diff --git a/lib/misc/hostinfoPosix.c b/open-vm-tools/lib/misc/hostinfoPosix.c
+index 8fa18cc..9874c2a 100644
+--- a/lib/misc/hostinfoPosix.c
++++ b/lib/misc/hostinfoPosix.c
+@@ -185,6 +185,7 @@ static const DistroInfo distroArray[] = {
+ {"Gentoo", "/etc/gentoo-release"},
+ {"Novell", "/etc/nld-release"},
+ {"Ubuntu", "/etc/lsb-release"},
++ {"Alpine", "/etc/alpine-release"},
+ {"Annvix", "/etc/annvix-release"},
+ {"Arch", "/etc/arch-release"},
+ {"Arklinux", "/etc/arklinux-release"},
+@@ -545,6 +546,8 @@ HostinfoGetOSShortName(char *distro, // IN: full distro name
+ Str_Strcpy(distroShort, STR_OS_TURBO, distroShortSize);
+ } else if (strstr(distroLower, "sun")) {
+ Str_Strcpy(distroShort, STR_OS_SUN_DESK, distroShortSize);
++ } else if (strstr(distroLower, "alpine")) {
++ Str_Strcpy(distroShort, STR_OS_ALPINE, distroShortSize);
+ } else if (strstr(distroLower, "annvix")) {
+ Str_Strcpy(distroShort, STR_OS_ANNVIX, distroShortSize);
+ } else if (strstr(distroLower, "arch")) {
+--
+1.7.11.1
+
diff --git a/main/open-vm-tools/APKBUILD b/main/open-vm-tools/APKBUILD
index 13ef2eac3b..03e74dc8d3 100644
--- a/main/open-vm-tools/APKBUILD
+++ b/main/open-vm-tools/APKBUILD
@@ -2,7 +2,7 @@
pkgname=open-vm-tools
pkgver=2012.03.13
_pkgsubver=651368
-pkgrel=2
+pkgrel=3
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="http://open-vm-tools.sourceforge.net/"
arch="all"
@@ -20,6 +20,7 @@ source="http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-$_p
iconv-uclibc.patch
uclibc-stubs.patch
libm.patch
+ 0001-lib-misc-Recognize-Alpine-Linux.patch
open-vm-tools.initd
"
@@ -86,4 +87,5 @@ md5sums="a664206443d5de53f5f8ee8d5fe6c2d7 open-vm-tools-2012.03.13-651368.tar.g
89c7449323ddac4666b73a8467baf95a iconv-uclibc.patch
30a4161baf6274ac9cceb879460cd894 uclibc-stubs.patch
7d02fc25aba5c248f3d98dac238f175b libm.patch
+87b131c2208b32d9c0bb6fbacd7f75a9 0001-lib-misc-Recognize-Alpine-Linux.patch
905ef6a3bac87c9ba2e5d3897ca230e7 open-vm-tools.initd"