aboutsummaryrefslogtreecommitdiffstats
path: root/main/open-vm-tools
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-10-14 11:22:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-10-14 11:22:24 +0200
commitd696932ea9aa5d332298bb13bf6e587c8e230b56 (patch)
treeafb7436097d19b897767579a5103a53190abecba /main/open-vm-tools
parent952fdbfeb54d33019ef19a0a1116007da6bc82ab (diff)
downloadaports-d696932ea9aa5d332298bb13bf6e587c8e230b56.tar.bz2
aports-d696932ea9aa5d332298bb13bf6e587c8e230b56.tar.xz
main/open-vm-tools: reformat apkbuild and rebuild against libtirpc
Diffstat (limited to 'main/open-vm-tools')
-rw-r--r--main/open-vm-tools/APKBUILD35
1 files changed, 6 insertions, 29 deletions
diff --git a/main/open-vm-tools/APKBUILD b/main/open-vm-tools/APKBUILD
index 4ed051ef49..562a2f1832 100644
--- a/main/open-vm-tools/APKBUILD
+++ b/main/open-vm-tools/APKBUILD
@@ -3,7 +3,7 @@ pkgname=open-vm-tools
pkgver=10.0.7
_pkgsubver=${pkgver#*_p}
_ver=${pkgver/_p/-}
-pkgrel=3
+pkgrel=4
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="https://github.com/vmware/open-vm-tools/"
@@ -32,38 +32,15 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/vmware/open-vm-tools/archive
open-vm-tools.initd
"
-_builddir="$srcdir"/open-vm-tools-stable-$_ver
-#/open-vm-tools
-
-prepare() {
- cd "$_builddir"
-
- for patch in $source; do
- case $patch in
- *.patch)
- msg "Applying patch $patch"
- patch -p1 -i "$srcdir"/$patch || return 1
- ;;
- esac
- done
-
- cd open-vm-tools
-
- # workaround automake-1.10 issue
- # http://ramblingfoo.blogspot.com/2007/07/required-file-configrpath-not-
- mkdir -p config
- touch config/config.rpath
- libtoolize --force --install && aclocal -I m4 -I config && autoconf \
- && automake --add-missing
-}
+builddir="$srcdir"/open-vm-tools-stable-$_ver
build() {
export CUSTOM_PROCPS_NAME="procps"
export CFLAGS="$CFLAGS -Wno-unused-but-set-variable -fpermissive -D_GNU_SOURCE"
export CXXFLAGS="$CXXFLAGS -std=gnu++11 -fpermissive"
- mkdir "$_builddir"/build
- cd "$_builddir"/build
- ../open-vm-tools/configure \
+ cd "$builddir"/open-vm-tools
+ autoreconf -vif || return 1
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -81,7 +58,7 @@ build() {
}
package() {
- cd "$_builddir"/build
+ cd "$builddir"/open-vm-tools
make install DESTDIR=$pkgdir || return 1
install -Dm755 "$srcdir"/open-vm-tools.initd \
"$pkgdir"/etc/init.d/open-vm-tools