aboutsummaryrefslogtreecommitdiffstats
path: root/main/openpgm
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-20 14:06:49 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-20 14:07:46 +0000
commit78075744e7705bf9c5af51708b119ce1f2b09645 (patch)
tree2fb113ce57a05d499612689248e9ef067a6c8bf0 /main/openpgm
parent2025a625e69398c4a81942971a893e11a9b31a51 (diff)
downloadaports-78075744e7705bf9c5af51708b119ce1f2b09645.tar.bz2
aports-78075744e7705bf9c5af51708b119ce1f2b09645.tar.xz
main/openpgm: new aport
An implementation of the PGM reliable multicast protocol https://code.google.com/p/openpgm/
Diffstat (limited to 'main/openpgm')
-rw-r--r--main/openpgm/APKBUILD54
-rw-r--r--main/openpgm/openpgm-fix-includes.patch30
2 files changed, 84 insertions, 0 deletions
diff --git a/main/openpgm/APKBUILD b/main/openpgm/APKBUILD
new file mode 100644
index 0000000000..55d57f3458
--- /dev/null
+++ b/main/openpgm/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=openpgm
+pkgver=5.2.122
+pkgrel=0
+pkgdesc="An implementation of the PGM reliable multicast protocol"
+url="https://code.google.com/p/openpgm/"
+arch="all"
+license="LGPL 2.1"
+depends=""
+depends_dev=""
+makedepends="$depends_dev python perl"
+install=""
+subpackages="$pkgname-dev"
+source="https://openpgm.googlecode.com/files/libpgm-$pkgver.tar.bz2
+ openpgm-fix-includes.patch"
+
+_builddir="$srcdir"/libpgm-$pkgver/openpgm/pgm/
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ CFLAGS="$CFLAGS -D_GNU_SOURCE" \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+}
+
+md5sums="06d6e16bc9064379caf0f8fe979dc785 libpgm-5.2.122.tar.bz2
+11816d65ee6afc71d795d9ddbc0552d1 openpgm-fix-includes.patch"
+sha256sums="2f6fcdad7fcf08368bce100db2598abdd57cb1e55869df68c0032a12ffe86d93 libpgm-5.2.122.tar.bz2
+7030405c450251953841866a08641ac329384eacbc036f4954f5f6461f71887d openpgm-fix-includes.patch"
+sha512sums="dddd5c30f7ae9a6a2ca9738010d4e6a1b856f3d7e1636bb43ef697a0b07ad6f058978d6f21cc3f6efe0c21b48d71d496d1e914bd05e33ed6cfbda8b96821fa2f libpgm-5.2.122.tar.bz2
+6689ccafa00a9d436fb6074b6454df4443daa2e62db47c64a962dfb105ce2d0f85c79059aa27ac9834572cd30112e7f0407e24dfd995285fa7ac921d70214229 openpgm-fix-includes.patch"
diff --git a/main/openpgm/openpgm-fix-includes.patch b/main/openpgm/openpgm-fix-includes.patch
new file mode 100644
index 0000000000..6f1e5901fc
--- /dev/null
+++ b/main/openpgm/openpgm-fix-includes.patch
@@ -0,0 +1,30 @@
+--- ./include/pgm/types.h
++++ ./include/pgm/types.h
+@@ -27,6 +27,7 @@
+
+ #ifndef _MSC_VER
+ # include <sys/param.h>
++# include <sys/types.h>
+ #endif
+ #include <pgm/macros.h>
+
+--- ./include/impl/security.h
++++ ./include/impl/security.h
+@@ -33,7 +33,6 @@
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <sys/types.h>
+-#include <sys/timeb.h>
+ #include <impl/i18n.h>
+ #include <impl/errno.h>
+ #include <impl/string.h>
+@@ -41,6 +40,8 @@
+ PGM_BEGIN_DECLS
+
+ #ifdef HAVE_FTIME
++#include <sys/timeb.h>
++
+ static inline
+ errno_t
+ # if !defined( _WIN32 )
+