aboutsummaryrefslogtreecommitdiffstats
path: root/main/parole
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-28 07:32:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-28 07:33:24 +0000
commit0d6423e739d38e6c53f8e3a95a61a3bfdbf91adc (patch)
treec7c64db2f67bfe5bcae3eb7b6748de5db4f691f8 /main/parole
parent7b94205224a46b9506c90f14d9ae29da06839dd0 (diff)
downloadaports-0d6423e739d38e6c53f8e3a95a61a3bfdbf91adc.tar.bz2
aports-0d6423e739d38e6c53f8e3a95a61a3bfdbf91adc.tar.xz
main/parole: build fix
needs to link to -lX11
Diffstat (limited to 'main/parole')
-rw-r--r--main/parole/APKBUILD19
-rw-r--r--main/parole/libx11.patch11
2 files changed, 25 insertions, 5 deletions
diff --git a/main/parole/APKBUILD b/main/parole/APKBUILD
index 13af68de70..b971dab860 100644
--- a/main/parole/APKBUILD
+++ b/main/parole/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=parole
pkgver=0.2.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Media player for the Xfce desktop"
url="http://goodies.xfce.org/projects/applications/parole/"
arch="all"
@@ -12,10 +12,18 @@ makedepends="libxfcegui4-dev libxfce4util-dev intltool gstreamer-dev bash
gst-plugins-base-dev libsm-dev taglib-dev libnotify-dev"
install=
subpackages="$pkgname-dev $pkgname-lang"
-source="http://archive.xfce.org/src/apps/parole/0.2/parole-$pkgver.tar.bz2"
+# the libx11 is a hack. The real solution is filed in
+# https://bugzilla.xfce.org/show_bug.cgi?id=6244
+source="http://archive.xfce.org/src/apps/parole/0.2/parole-$pkgver.tar.bz2
+ libx11.patch"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -23,8 +31,8 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --enable-browser-plugin \
- --infodir=/usr/share/info
+ --infodir=/usr/share/info \
+ || return 1
make || return 1
}
@@ -34,4 +42,5 @@ package() {
find "$pkgdir" -name '*.la' -delete
}
-md5sums="5d7e5ab7535bdf89508a8d7e551f9187 parole-0.2.0.6.tar.bz2"
+md5sums="5d7e5ab7535bdf89508a8d7e551f9187 parole-0.2.0.6.tar.bz2
+97b18d6e09433458439f6c7325d839b1 libx11.patch"
diff --git a/main/parole/libx11.patch b/main/parole/libx11.patch
new file mode 100644
index 0000000000..4575551a63
--- /dev/null
+++ b/main/parole/libx11.patch
@@ -0,0 +1,11 @@
+--- ./src/Makefile.in.orig
++++ ./src/Makefile.in
+@@ -412,7 +412,7 @@
+ $(LIBXFCE4GUI_LIBS) \
+ $(GST_VIDEO_LIBS) \
+ $(GST_INTERFACES_LIBS) \
+- $(TAGLIBC_LIBS)
++ $(TAGLIBC_LIBS) -lX11
+
+ parole_glib_enum_headers = \
+ parole-conf.h \