aboutsummaryrefslogtreecommitdiffstats
path: root/main/parted
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-08 08:17:04 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-08 08:17:04 +0000
commit9c5cd3c329a40ba4559cc1d8c7d17a9bf95c237b (patch)
tree51e2b4f7ae44eac1f8b42a415133b45a96bf61e3 /main/parted
parent8b1a5deb53f63da911d2ffa736bcb835f72f0294 (diff)
downloadaports-9c5cd3c329a40ba4559cc1d8c7d17a9bf95c237b.tar.bz2
aports-9c5cd3c329a40ba4559cc1d8c7d17a9bf95c237b.tar.xz
main/parted: fix musl build
Diffstat (limited to 'main/parted')
-rw-r--r--main/parted/APKBUILD27
-rw-r--r--main/parted/fix-includes.patch10
-rw-r--r--main/parted/nocxx.patch15
3 files changed, 33 insertions, 19 deletions
diff --git a/main/parted/APKBUILD b/main/parted/APKBUILD
index 9bac464fd5..7c03d561bf 100644
--- a/main/parted/APKBUILD
+++ b/main/parted/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=parted
pkgver=3.1
-pkgrel=0
+pkgrel=1
pkgdesc="Utility to create, destroy, resize, check and copy partitions"
url="http://www.gnu.org/software/parted/parted.html"
arch="all"
@@ -9,9 +9,21 @@ license="GPL3"
subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends="pkgconfig e2fsprogs-dev readline-dev ncurses-dev lvm2-dev bash"
-source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz"
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+ fix-includes.patch"
_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
./configure \
@@ -20,7 +32,6 @@ build() {
--prefix=/usr \
--disable-debug \
--disable-nls \
- --disable-Werror \
|| return 1
make || return 1
}
@@ -29,5 +40,13 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/*.la || return 1
+ rm -rf "$pkgdir"/usr/lib/charset.alias
+ rmdir -p "$pkgdir"/usr/lib 2>/dev/null
+ return 0
}
-md5sums="5d89d64d94bcfefa9ce8f59f4b81bdcb parted-3.1.tar.xz"
+md5sums="5d89d64d94bcfefa9ce8f59f4b81bdcb parted-3.1.tar.xz
+e87ffa1171acbebfa9d2475a093e7e64 fix-includes.patch"
+sha256sums="5e9cc1f91eaf016e5033d85b9b893fd6d3ffaca532a48de1082df9b94225ca15 parted-3.1.tar.xz
+f87c9290e861b969f4520a1af84ebf4b8f5f1437c1d78ee235d5ffcda3bffe84 fix-includes.patch"
+sha512sums="f29a67a16cf79f08abbfc5eeb6ad0480d834aa50e715378626dc89e3b12ce71f19202e9f38429e5521ebe877c4e74ff1e08f0b0ecbdbe79ba1c51fdcbef6e852 parted-3.1.tar.xz
+55ee63c218d1867c0f2c596e7c3eec5c42af160181456cc551fe3d432eabed0ac2dd3a3955ff0c375f76aeec8071e7f55a32834b87a0d39b8ef30361f671bfdd fix-includes.patch"
diff --git a/main/parted/fix-includes.patch b/main/parted/fix-includes.patch
new file mode 100644
index 0000000000..c6eff0eb22
--- /dev/null
+++ b/main/parted/fix-includes.patch
@@ -0,0 +1,10 @@
+--- parted-3.1.orig/libparted/fs/xfs/platform_defs.h
++++ parted-3.1/libparted/fs/xfs/platform_defs.h
+@@ -35,6 +35,7 @@
+ #define __XFS_PLATFORM_DEFS_H__
+
+ #include <stdio.h>
++#include <fcntl.h>
+ #include <stdarg.h>
+ #include <assert.h>
+ #include <endian.h>
diff --git a/main/parted/nocxx.patch b/main/parted/nocxx.patch
deleted file mode 100644
index beb1ab9006..0000000000
--- a/main/parted/nocxx.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/configure 2004-12-07 21:34:23.205172545 +0000
-+++ b/configure 2004-12-07 21:37:17.726654782 +0000
-@@ -5148,10 +5148,8 @@
- :
- else
- { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
--See \`config.log' for more details." >&5
--echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
--See \`config.log' for more details." >&2;}
-- { (exit 1); exit 1; }; }
-+See \`config.log' for more details." >&5;}
-+ { echo "C++ sucks, ignoring ..." >&5; }; }
- fi
-
- ac_ext=cc