aboutsummaryrefslogtreecommitdiffstats
path: root/main/pcre
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-08-28 10:39:22 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 10:40:24 +0000
commit38d68285cae7efaa99e98e72e67d1b9c10012f4a (patch)
treedd4b2e65f234c919a78e86a8771d28dbb6eead90 /main/pcre
parent60922330bc613354fdfce8f8214b835018fdf12a (diff)
downloadaports-38d68285cae7efaa99e98e72e67d1b9c10012f4a.tar.bz2
aports-38d68285cae7efaa99e98e72e67d1b9c10012f4a.tar.xz
main/pcre: fix make check
- disable locale dependent tests - paxmark JIT requiring tests
Diffstat (limited to 'main/pcre')
-rw-r--r--main/pcre/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/main/pcre/APKBUILD b/main/pcre/APKBUILD
index 341e4a2dba..7d9e8896d8 100644
--- a/main/pcre/APKBUILD
+++ b/main/pcre/APKBUILD
@@ -9,6 +9,7 @@ arch="all"
license="BSD"
depends=
makedepends=""
+checkdepends="paxmark"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcrecpp libpcre16 libpcre32"
source="ftp://ftp.csx.cam.ac.uk/pub/software/programming/$pkgname/$pkgname-$pkgver.tar.bz2
@@ -47,6 +48,13 @@ package() {
check() {
cd "$builddir"
+
+ # paxmark tests requiring JIT
+ ./pcre_jit_test &>/dev/null || ./pcretest &>/dev/null < /dev/null || true
+ paxmark -m .libs/lt-pcre_jit_test .libs/lt-pcretest
+ # skip locale specific tests
+ sed -i -e 's/do3=yes//g' RunTest
+
make check
}