aboutsummaryrefslogtreecommitdiffstats
path: root/main/pcre
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-01-15 12:54:34 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-01-15 12:54:34 +0100
commit6f02da3b116ac9d5aeddf01a0a8d4875dc0e859c (patch)
tree9f3cc08a474eb2e9aa212a30ffb1240aa0beb2ce /main/pcre
parenta8f28137cd46ba23d94fc24d8c4f08c3b52e53e1 (diff)
downloadaports-6f02da3b116ac9d5aeddf01a0a8d4875dc0e859c.tar.bz2
aports-6f02da3b116ac9d5aeddf01a0a8d4875dc0e859c.tar.xz
main/pcre: improve abuild
Diffstat (limited to 'main/pcre')
-rw-r--r--main/pcre/APKBUILD18
1 files changed, 4 insertions, 14 deletions
diff --git a/main/pcre/APKBUILD b/main/pcre/APKBUILD
index a2b9969402..f68e9e9147 100644
--- a/main/pcre/APKBUILD
+++ b/main/pcre/APKBUILD
@@ -10,21 +10,11 @@ depends=
makedepends=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcrecpp libpcre16 libpcre32"
-source="ftp://ftp.csx.cam.ac.uk/pub/software/programming/$pkgname/$pkgname-$pkgver.tar.bz2
- "
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="ftp://ftp.csx.cam.ac.uk/pub/software/programming/$pkgname/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -44,7 +34,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}