aboutsummaryrefslogtreecommitdiffstats
path: root/main/pcre
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2017-08-06 14:07:45 +0300
committerFrancesco Colista <fcolista@alpinelinux.org>2017-08-09 06:30:30 +0000
commitf745df7c0bd4c534290b6777b1200b87ae49219e (patch)
tree637be30a44da20d6dfe25a8ecb01a26b24ac4a70 /main/pcre
parent3d3be1c217d51241cc5f1c5fc5f509777af95ee5 (diff)
downloadaports-f745df7c0bd4c534290b6777b1200b87ae49219e.tar.bz2
aports-f745df7c0bd4c534290b6777b1200b87ae49219e.tar.xz
main/pcre: upgrade to 8.41
Diffstat (limited to 'main/pcre')
-rw-r--r--main/pcre/APKBUILD8
-rw-r--r--main/pcre/CVE-2017-7186.patch57
2 files changed, 3 insertions, 62 deletions
diff --git a/main/pcre/APKBUILD b/main/pcre/APKBUILD
index 123eda15bb..91b22aee1a 100644
--- a/main/pcre/APKBUILD
+++ b/main/pcre/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pcre
-pkgver=8.40
-pkgrel=2
+pkgver=8.41
+pkgrel=0
pkgdesc="Perl-compatible regular expression library"
url="http://pcre.sourceforge.net"
arch="all"
@@ -12,7 +12,6 @@ makedepends=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcrecpp libpcre16 libpcre32"
source="ftp://ftp.csx.cam.ac.uk/pub/software/programming/$pkgname/$pkgname-$pkgver.tar.bz2
- CVE-2017-7186.patch
"
# secfixes:
@@ -71,5 +70,4 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="b4c27eafbdf33bd7a1384655b1936f4be3bc6745c072347eb26e988896c52664bd85ac42444da1be78b6e20f45b6c7e5921f5f20f5b0741b5bd3d9844e5bd4e2 pcre-8.40.tar.bz2
-3644a2d9895a974192dfe778e5dcdbf0eacc592ccedeb37caf3d9426668ee8fda5fc16f87e38c112943e619d1b35a498ccbf4b4a1c2da58821198bbcc180be31 CVE-2017-7186.patch"
+sha512sums="cc9cdbeb98c010fe4f093a019bebfb91965dae4c6a48f8e49c38ec8df7d9da7f0d32c12fc58f22c51f1c2f010e72b65bcbf8bbf180060e93edf464fa9a7c3551 pcre-8.41.tar.bz2"
diff --git a/main/pcre/CVE-2017-7186.patch b/main/pcre/CVE-2017-7186.patch
deleted file mode 100644
index 256325b563..0000000000
--- a/main/pcre/CVE-2017-7186.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-Patch source:
-https://vcs.pcre.org/pcre/code/trunk/pcre_internal.h?r1=1649&r2=1688&sortby=date
-https://vcs.pcre.org/pcre/code/trunk/pcre_ucd.c?r1=1490&r2=1688&sortby=date
-
---- a/pcre_internal.h 2016/05/21 13:34:44 1649
-+++ b/pcre_internal.h 2017/02/24 17:30:30 1688
-@@ -2772,6 +2772,9 @@
- extern const pcre_uint16 PRIV(ucd_stage2)[];
- extern const pcre_uint32 PRIV(ucp_gentype)[];
- extern const pcre_uint32 PRIV(ucp_gbtable)[];
-+#ifdef COMPILE_PCRE32
-+extern const ucd_record PRIV(dummy_ucd_record)[];
-+#endif
- #ifdef SUPPORT_JIT
- extern const int PRIV(ucp_typerange)[];
- #endif
-@@ -2780,9 +2783,15 @@
- /* UCD access macros */
-
- #define UCD_BLOCK_SIZE 128
--#define GET_UCD(ch) (PRIV(ucd_records) + \
-+#define REAL_GET_UCD(ch) (PRIV(ucd_records) + \
- PRIV(ucd_stage2)[PRIV(ucd_stage1)[(int)(ch) / UCD_BLOCK_SIZE] * \
- UCD_BLOCK_SIZE + (int)(ch) % UCD_BLOCK_SIZE])
-+
-+#ifdef COMPILE_PCRE32
-+#define GET_UCD(ch) ((ch > 0x10ffff)? PRIV(dummy_ucd_record) : REAL_GET_UCD(ch))
-+#else
-+#define GET_UCD(ch) REAL_GET_UCD(ch)
-+#endif
-
- #define UCD_CHARTYPE(ch) GET_UCD(ch)->chartype
- #define UCD_SCRIPT(ch) GET_UCD(ch)->script
-
---- a/pcre_ucd.c 2014/06/19 07:51:39 1490
-+++ a/pcre_ucd.c 2017/02/24 17:30:30 1688
-@@ -38,6 +38,20 @@
- const pcre_uint32 PRIV(ucd_caseless_sets)[] = {0};
- #else
-
-+/* If the 32-bit library is run in non-32-bit mode, character values
-+greater than 0x10ffff may be encountered. For these we set up a
-+special record. */
-+
-+#ifdef COMPILE_PCRE32
-+const ucd_record PRIV(dummy_ucd_record)[] = {{
-+ ucp_Common, /* script */
-+ ucp_Cn, /* type unassigned */
-+ ucp_gbOther, /* grapheme break property */
-+ 0, /* case set */
-+ 0, /* other case */
-+ }};
-+#endif
-+
- /* When recompiling tables with a new Unicode version, please check the
- types in this structure definition from pcre_internal.h (the actual
- field names will be different):