aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-apache-logformat-compiler
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-05 08:20:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-05 08:25:16 +0000
commitcf9c664c9474000794344ba53aa980f074eaf4fa (patch)
treed91e436385096ae42139b542da0e6f8033032ffc /main/perl-apache-logformat-compiler
parent2c9549eb5a2e83d118a14808b02670118ef790c2 (diff)
downloadaports-cf9c664c9474000794344ba53aa980f074eaf4fa.tar.bz2
aports-cf9c664c9474000794344ba53aa980f074eaf4fa.tar.xz
main/perl-apache-logformat-compiler: new aport
needed by perl-plack
Diffstat (limited to 'main/perl-apache-logformat-compiler')
-rw-r--r--main/perl-apache-logformat-compiler/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/perl-apache-logformat-compiler/APKBUILD b/main/perl-apache-logformat-compiler/APKBUILD
new file mode 100644
index 0000000000..b5f56eb1f6
--- /dev/null
+++ b/main/perl-apache-logformat-compiler/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-apache-logformat-compiler
+_pkgreal=Apache-LogFormat-Compiler
+pkgver=0.32
+pkgrel=0
+pkgdesc="Compile a log format string to perl-code "
+url="http://search.cpan.org/dist/Apache-LogFormat-Compiler/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-posix-strftime-compiler"
+cpanmakedepends=" perl-test-requires perl-http-message perl-try-tiny perl-uri perl-test-mocktime "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/K/KA/KAZEBURO/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="0abb3275f934c7ac41d7a83c7d0565ad Apache-LogFormat-Compiler-0.32.tar.gz"
+sha256sums="bc112cdbc32f2e93c10bf661f39de509036e01c20c3a702a22cdb0be4426dd7f Apache-LogFormat-Compiler-0.32.tar.gz"
+sha512sums="aee9443bd067dc9a623b8f694e3d0c8fd2d3b7e4fe6a547153eff0c2046f22a4503a9b999df2df92bee1eb06c17cbbe626555bd70018891784af51d7623ac27f Apache-LogFormat-Compiler-0.32.tar.gz"