aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-datetime
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-02 14:09:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-02 14:09:33 +0000
commit153c89da6709d7330a271be726104bbbdfcc9858 (patch)
tree3abb00fd5739b15d1f027144d1cc77bfaceb904d /main/perl-datetime
parent0d7c49b1e9decddf161bcb4e4c12ab46c0e794ec (diff)
downloadaports-153c89da6709d7330a271be726104bbbdfcc9858.tar.bz2
aports-153c89da6709d7330a271be726104bbbdfcc9858.tar.xz
main/perl-*: moved to main
most of the have test scripts
Diffstat (limited to 'main/perl-datetime')
-rw-r--r--main/perl-datetime/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/perl-datetime/APKBUILD b/main/perl-datetime/APKBUILD
new file mode 100644
index 0000000000..6410ab936d
--- /dev/null
+++ b/main/perl-datetime/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-datetime
+pkgver=0.70
+pkgrel=0
+pkgdesc="DateTime perl module"
+url="http://search.cpan.org/dist/DateTime/"
+arch="all"
+license="GPLv2 or Artistic"
+depends="perl perl-datetime-locale perl-test-exception perl-math-round
+ perl-datetime-timezone"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-$pkgver.tar.gz"
+
+_builddir="$srcdir"/DateTime-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ unset CFLAGS
+ perl Build.PL installdirs=vendor || return 1
+ ./Build
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="228a3ca93b49e308fc7a3b7a47341ab3 DateTime-0.70.tar.gz"