aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-encode
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-27 14:12:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-28 17:13:57 +0000
commitce485c030d81eb0672188af30062b50f8a416282 (patch)
treeea75503044d9a38182f7512c1936342e13f89700 /main/perl-encode
parent3fd387f4994fc3b3e701c56aca4f3a41634ed786 (diff)
downloadaports-ce485c030d81eb0672188af30062b50f8a416282.tar.bz2
aports-ce485c030d81eb0672188af30062b50f8a416282.tar.xz
main/perl-encode: upgrade to 2.93 and modernize
Diffstat (limited to 'main/perl-encode')
-rw-r--r--main/perl-encode/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/main/perl-encode/APKBUILD b/main/perl-encode/APKBUILD
index c21bc90c00..b7df54f84e 100644
--- a/main/perl-encode/APKBUILD
+++ b/main/perl-encode/APKBUILD
@@ -3,14 +3,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-encode
_pkgreal=Encode
-pkgver=2.88
-pkgrel=2
+pkgver=2.93
+pkgrel=0
pkgdesc="character encodings in Perl"
url="http://search.cpan.org/dist/Encode/"
arch="all"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
depends_dev="$pkgname-utils"
makedepends="perl-dev $cpanmakedepends"
@@ -27,12 +27,17 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
@@ -49,11 +54,11 @@ dev() {
default_dev
replaces="perl-dev"
mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/enc2xs "$subpkgdir"/usr/bin || return 1
+ mv "$pkgdir"/usr/bin/enc2xs "$subpkgdir"/usr/bin
local file; for file in $(find "$pkgdir" -name "*.e2x"); do
file=${file#$pkgdir/}
mkdir -p "$subpkgdir"/${file%/*} || return 1
- mv "$pkgdir"/$file "$subpkgdir"/$file || return 1
+ mv "$pkgdir"/$file "$subpkgdir"/$file
done
}
@@ -63,10 +68,8 @@ doc() {
local file; for file in $(find "$pkgdir" -name "*.pod"); do
file=${file#$pkgdir/}
mkdir -p "$subpkgdir"/${file%/*} || return 1
- mv "$pkgdir"/$file "$subpkgdir"/$file || return 1
+ mv "$pkgdir"/$file "$subpkgdir"/$file
done
}
-md5sums="119e8668e1d7b128ce39375445526a7e Encode-2.88.tar.gz"
-sha256sums="e45ce444dfc87b01a16d3029d9a027beab1fdeff9860699b4b62a141420be338 Encode-2.88.tar.gz"
-sha512sums="1261415abd9c2ad5f8d009441e1f2f541d7e94c570549d3b895df57d5c7480087ec646b2691724007a5797238cb7249347d9b97b7c46018973a7ef33274fe162 Encode-2.88.tar.gz"
+sha512sums="bdb72139e3e9ad1c2b829167d97e429462395ff1c6f050cbc55ea6605b927de58a75a4c4496f2064a378efc4b3cc6c972821a417f302ca36b02aa104b395aba2 Encode-2.93.tar.gz"