aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-html-formattext-withlinks-andtables
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-05-25 11:36:51 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-05-25 11:39:38 +0000
commit39d57d8175de808996c28f22244641045eb9ed1c (patch)
tree7b5ebd7eff369c1c3b03ab60e0f5161c9946adef /main/perl-html-formattext-withlinks-andtables
parent3df67afdee29b5b2db415c3d91fc14ef439bb541 (diff)
downloadaports-39d57d8175de808996c28f22244641045eb9ed1c.tar.bz2
aports-39d57d8175de808996c28f22244641045eb9ed1c.tar.xz
main/perl-html-formattext-withlinks-andtables: upgrade to 0.07
Add check(), modernize APKBUILD
Diffstat (limited to 'main/perl-html-formattext-withlinks-andtables')
-rw-r--r--main/perl-html-formattext-withlinks-andtables/APKBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/main/perl-html-formattext-withlinks-andtables/APKBUILD b/main/perl-html-formattext-withlinks-andtables/APKBUILD
index 40950ce3d4..c7241ffb3b 100644
--- a/main/perl-html-formattext-withlinks-andtables/APKBUILD
+++ b/main/perl-html-formattext-withlinks-andtables/APKBUILD
@@ -3,41 +3,39 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-html-formattext-withlinks-andtables
_pkgreal=HTML-FormatText-WithLinks-AndTables
-pkgver=0.06
+pkgver=0.07
pkgrel=0
pkgdesc="Perl module for HTML-FormatText-WithLinks-AndTables"
url="http://search.cpan.org/dist/HTML-FormatText-WithLinks-AndTables/"
arch="noarch"
license="GPL PerlArtistic"
-cpandepends=""
+cpandepends="perl-html-formattext-withlinks"
cpanmakedepends=""
-depends="$cpandepends perl-html-formattext-withlinks"
+depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
+checkdepends="perl-test-pod"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/D/DA/DALEEVANS/$_pkgreal-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_pkgreal-$pkgver"
-
-prepare() {
- cd "$_builddir"
- return 0
-}
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
if [ -e Build.PL ]; then
- perl Build.PL installdirs=vendor || return 1
+ perl Build.PL installdirs=vendor
else
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
fi
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="bd214ca080379cc09f0b2eef62bf3d0f HTML-FormatText-WithLinks-AndTables-0.06.tar.gz"
-sha256sums="e5b23f0475fb81fd6fed688bb914295a39542b3e5b43c8517494226a52d868fa HTML-FormatText-WithLinks-AndTables-0.06.tar.gz"
-sha512sums="c930fcc5919d20a67a00826aec11d1d2416a3ae145cf30acee98aa45bc64523858ba49907957c5772b4bedaa1e79ed7a0afef3101c29f913fcf983ce1dddd4c2 HTML-FormatText-WithLinks-AndTables-0.06.tar.gz"
+sha512sums="3deea4406f7f9dd55d22d60c169d3889be7ef802a43507fb8b608c45ecdff52f743c9cb3a4703f1e44cdcf033c4c64b4c993192fe1a39efc9eae78c6fb66ff3e HTML-FormatText-WithLinks-AndTables-0.07.tar.gz"