aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-image-exiftool
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-05 23:37:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-05 23:37:36 +0000
commit48218f92d147e8d448d6e4f1cf8a3f3002e4b03f (patch)
treed58beb1ae40390ad3935ae6d7a348499210f6add /main/perl-image-exiftool
parentf6117b59ba245507249addd524a66de211f00e35 (diff)
downloadaports-48218f92d147e8d448d6e4f1cf8a3f3002e4b03f.tar.bz2
aports-48218f92d147e8d448d6e4f1cf8a3f3002e4b03f.tar.xz
main/perl-image-exiftool: modernize builddir
Diffstat (limited to 'main/perl-image-exiftool')
-rw-r--r--main/perl-image-exiftool/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/perl-image-exiftool/APKBUILD b/main/perl-image-exiftool/APKBUILD
index fe8c7fc097..482345891d 100644
--- a/main/perl-image-exiftool/APKBUILD
+++ b/main/perl-image-exiftool/APKBUILD
@@ -13,20 +13,20 @@ install=""
subpackages="$pkgname-doc exiftool"
source="http://www.sno.phy.queensu.ca/~phil/exiftool/Image-ExifTool-$pkgver.tar.gz"
-_builddir="$srcdir"/Image-ExifTool-$pkgver
+builddir="$srcdir"/Image-ExifTool-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$_builddir"
+ cd "$builddir"
make test
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
# creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete