aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-lwp-mediatypes
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-17 04:37:13 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:40:48 +0000
commit836b98b3c7314d216566a7f1bfba21a6996905ae (patch)
treec3d681067143c5107011a21cf3d12beab82a8b9c /main/perl-lwp-mediatypes
parent1f7f771c4cbeb582b3a4ab79356ba302732c6ecf (diff)
downloadaports-836b98b3c7314d216566a7f1bfba21a6996905ae.tar.bz2
aports-836b98b3c7314d216566a7f1bfba21a6996905ae.tar.xz
main/perl*: mass test suite addition + modernisation of 18 Perl packages
Diffstat (limited to 'main/perl-lwp-mediatypes')
-rw-r--r--main/perl-lwp-mediatypes/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/main/perl-lwp-mediatypes/APKBUILD b/main/perl-lwp-mediatypes/APKBUILD
index 8f173f2232..174074fe9f 100644
--- a/main/perl-lwp-mediatypes/APKBUILD
+++ b/main/perl-lwp-mediatypes/APKBUILD
@@ -3,7 +3,7 @@
pkgname=perl-lwp-mediatypes
_realname=LWP-MediaTypes
pkgver=6.02
-pkgrel=0
+pkgrel=1
pkgdesc="Perl module - guess media type for a file or a URL"
url="http://search.cpan.org/~gaas"
arch="noarch"
@@ -15,16 +15,21 @@ replaces="perl-libwww"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_realname-$pkgver.tar.gz"
-_builddir="$srcdir/$_realname-$pkgver"
+builddir="$srcdir/$_realname-$pkgver"
build() {
- cd $_builddir
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd $_builddir
+ cd "$builddir"
make DESTDIR="$pkgdir" install
# creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete