aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-mailtools
diff options
context:
space:
mode:
authormepholic <meph@hxx.in>2017-11-21 18:23:07 -0800
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-28 17:16:58 +0000
commit017329a965af85ce60453755d8ffa2b42c884c80 (patch)
treea1106f42af897a125ebdcee7b941b6eacab90e3b /main/perl-mailtools
parent57568913de37dd6932ab6e75b8d5db8d9b5a1827 (diff)
downloadaports-017329a965af85ce60453755d8ffa2b42c884c80.tar.bz2
aports-017329a965af85ce60453755d8ffa2b42c884c80.tar.xz
main/perl-mailtools: point sources to new url
the source tarball for this package seems to no longer exist at the old location. the url has been updated to point to the correct location.
Diffstat (limited to 'main/perl-mailtools')
-rw-r--r--main/perl-mailtools/APKBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/main/perl-mailtools/APKBUILD b/main/perl-mailtools/APKBUILD
index ca8fe8a247..b8fb841d79 100644
--- a/main/perl-mailtools/APKBUILD
+++ b/main/perl-mailtools/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-mailtools
_pkgreal=MailTools
pkgver=2.18
-pkgrel=1
+pkgrel=2
pkgdesc="Various e-mail related modules"
url="http://search.cpan.org/dist/MailTools/"
arch="noarch"
@@ -16,25 +16,29 @@ provides="perl-mail-tools=$pkgver"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/$_pkgreal-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_pkgreal-$pkgver"
+source="http://cpan.metacpan.org/authors/id/M/MA/MARKOV/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}