aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-module-runtime
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-12 11:48:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-12 11:48:09 +0000
commitf90c52168f55da09a88dcd5619c480acfe8ea995 (patch)
treea7c2289d6d56bc2fcf80f20731698a66ad48723a /main/perl-module-runtime
parent797b5f2aed625ef9b33f737e27c432f367805b3d (diff)
downloadaports-f90c52168f55da09a88dcd5619c480acfe8ea995.tar.bz2
aports-f90c52168f55da09a88dcd5619c480acfe8ea995.tar.xz
main/perl-module-runtime: moved from testing
Diffstat (limited to 'main/perl-module-runtime')
-rw-r--r--main/perl-module-runtime/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/main/perl-module-runtime/APKBUILD b/main/perl-module-runtime/APKBUILD
new file mode 100644
index 0000000000..26eff5e3c3
--- /dev/null
+++ b/main/perl-module-runtime/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-module-runtime
+_pkgreal=Module-Runtime
+pkgver=0.011
+pkgrel=0
+pkgdesc="runtime module handling"
+url="http://search.cpan.org/dist/Module-Runtime/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-params-classify"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/Z/ZE/ZEFRAM/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="d0d2ab338c5bb2769a8f7db200cfdb2b Module-Runtime-0.011.tar.gz"