aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-sub-identify
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2014-12-25 14:46:54 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2014-12-25 14:46:54 +0000
commit9d67e907bc3c2ae4803e4fb24b9a712107bb7c7f (patch)
tree69eb72af4887332fcc31879c348b530f4b917385 /main/perl-sub-identify
parentdb86708adabdf07721b1a3ae93a82016f1ae9185 (diff)
downloadaports-9d67e907bc3c2ae4803e4fb24b9a712107bb7c7f.tar.bz2
aports-9d67e907bc3c2ae4803e4fb24b9a712107bb7c7f.tar.xz
testing/perl-sub-identify: moved to main
Diffstat (limited to 'main/perl-sub-identify')
-rw-r--r--main/perl-sub-identify/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/perl-sub-identify/APKBUILD b/main/perl-sub-identify/APKBUILD
new file mode 100644
index 0000000000..fd3eb01379
--- /dev/null
+++ b/main/perl-sub-identify/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-sub-identify
+_pkgreal=Sub-Identify
+pkgver=0.08
+pkgrel=0
+pkgdesc="Retrieve names of code references"
+url="http://search.cpan.org/dist/Sub-Identify/"
+arch="all"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/R/RG/RGARCIA/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="07fbd43c37a26f3ac1e12e854a5146dd Sub-Identify-0.08.tar.gz"
+sha256sums="ace7ef4f603f2ad95b496a4b1d4d5977720e776b364c5cf6ca1a6c6f6916335e Sub-Identify-0.08.tar.gz"
+sha512sums="5fe7855b45c8803e6a0fdbf0e28541207f76b1afe9f982b683b8c15f6579d5daff4f0eda91d2f3425c8ec38e8ca26764f4d8bc0927ac32c3004454465f8e5ba3 Sub-Identify-0.08.tar.gz"