aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-test-fatal
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-17 04:37:13 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:40:48 +0000
commit836b98b3c7314d216566a7f1bfba21a6996905ae (patch)
treec3d681067143c5107011a21cf3d12beab82a8b9c /main/perl-test-fatal
parent1f7f771c4cbeb582b3a4ab79356ba302732c6ecf (diff)
downloadaports-836b98b3c7314d216566a7f1bfba21a6996905ae.tar.bz2
aports-836b98b3c7314d216566a7f1bfba21a6996905ae.tar.xz
main/perl*: mass test suite addition + modernisation of 18 Perl packages
Diffstat (limited to 'main/perl-test-fatal')
-rw-r--r--main/perl-test-fatal/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/main/perl-test-fatal/APKBUILD b/main/perl-test-fatal/APKBUILD
index 7b60f0fe30..dd4466ba9b 100644
--- a/main/perl-test-fatal/APKBUILD
+++ b/main/perl-test-fatal/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-test-fatal
_pkgreal=Test-Fatal
pkgver=0.014
-pkgrel=0
+pkgrel=1
pkgdesc="incredibly simple helpers for testing code with exceptions"
url="http://search.cpan.org/dist/Test-Fatal/"
arch="noarch"
@@ -16,24 +16,27 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="7954f6d2e3607be10c0fbd69063a3d1b Test-Fatal-0.014.tar.gz"
-sha256sums="bcdcef5c7b2790a187ebca810b0a08221a63256062cfab3c3b98685d91d1cbb0 Test-Fatal-0.014.tar.gz"
sha512sums="339d9b33231f8c8d93c0f9374a51458d004568a2f3e28471976e954c35d27efd348f68fb56e3cabd11dc47d37e7ce46282eba967c156ba5081811d221c6a7523 Test-Fatal-0.014.tar.gz"