aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-test-leaktrace
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-06-15 13:55:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-15 20:07:16 +0000
commit39d4be194c3947adac6b35bfa29bf1e293193660 (patch)
treeb5e9b8b666e86d7e62abd02dd2aba810452620e2 /main/perl-test-leaktrace
parent9b578eb73e131071b09d66efa652480a1fddd112 (diff)
downloadaports-39d4be194c3947adac6b35bfa29bf1e293193660.tar.bz2
aports-39d4be194c3947adac6b35bfa29bf1e293193660.tar.xz
main/perl-test-leaktrace: rebuild against perl 5.26
Diffstat (limited to 'main/perl-test-leaktrace')
-rw-r--r--main/perl-test-leaktrace/APKBUILD27
-rw-r--r--main/perl-test-leaktrace/perl-5.26.patch12
2 files changed, 26 insertions, 13 deletions
diff --git a/main/perl-test-leaktrace/APKBUILD b/main/perl-test-leaktrace/APKBUILD
index 2f7f9ad1c9..abdca94e0f 100644
--- a/main/perl-test-leaktrace/APKBUILD
+++ b/main/perl-test-leaktrace/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-test-leaktrace
_pkgreal=Test-LeakTrace
pkgver=0.15
-pkgrel=2
+pkgrel=3
pkgdesc="Traces memory leaks"
url="http://search.cpan.org/dist/Test-LeakTrace/"
arch="all"
@@ -14,28 +14,29 @@ cpanmakedepends=" "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/$_pkgreal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/$_pkgreal-$pkgver.tar.gz
+ perl-5.26.patch
+ "
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$_builddir"
+build() {
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
-build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="5eac99e7882970f41886c3e0cec185d8 Test-LeakTrace-0.15.tar.gz"
-sha256sums="efb8b58b6981efc6c9c4b4a3b550728f8c179f3c8d57c05724873011c08de65e Test-LeakTrace-0.15.tar.gz"
-sha512sums="664d1648cc9ce229456ca0c27430bdd36ba1d9bf6907afce6c612b90d6885aa6a71caeceb266aec1f843287e6bcda35ac28eab2ad6b662019c0fcb87d7f0d6be Test-LeakTrace-0.15.tar.gz"
+sha512sums="664d1648cc9ce229456ca0c27430bdd36ba1d9bf6907afce6c612b90d6885aa6a71caeceb266aec1f843287e6bcda35ac28eab2ad6b662019c0fcb87d7f0d6be Test-LeakTrace-0.15.tar.gz
+6fa0cf487f0ceb5cfa9eeaffd34a3bb2bcef7fa800e48493e67e6f872dcff8186e2617191a5412612efee843764770da5c49049b4f78637d3f79e8ddaac57bd0 perl-5.26.patch"
diff --git a/main/perl-test-leaktrace/perl-5.26.patch b/main/perl-test-leaktrace/perl-5.26.patch
new file mode 100644
index 0000000000..af0b298f3a
--- /dev/null
+++ b/main/perl-test-leaktrace/perl-5.26.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index 69e904e..d90dea2 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,5 +1,7 @@
+ use strict;
+ use warnings;
++
++BEGIN { push @INC, '.'; }
+ use inc::Module::Install;
+
+ name 'Test-LeakTrace';