aboutsummaryrefslogtreecommitdiffstats
path: root/main/php/php-install-pear-xml.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-11 12:38:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-11 12:38:15 +0000
commit85656262f5d65aebc52916254d15785a9b3878c5 (patch)
tree6d2d9bf5416ca6e8ef1a8add3d604e2d8970c631 /main/php/php-install-pear-xml.patch
parent79253a23e0faf36c0a95b9fd3af96176250cb1ae (diff)
downloadaports-85656262f5d65aebc52916254d15785a9b3878c5.tar.bz2
aports-85656262f5d65aebc52916254d15785a9b3878c5.tar.xz
main/php: enable shared xml
we need patch the make install to find the xml.so
Diffstat (limited to 'main/php/php-install-pear-xml.patch')
-rw-r--r--main/php/php-install-pear-xml.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/main/php/php-install-pear-xml.patch b/main/php/php-install-pear-xml.patch
new file mode 100644
index 0000000000..f7a6fff58b
--- /dev/null
+++ b/main/php/php-install-pear-xml.patch
@@ -0,0 +1,15 @@
+--- ./pear/Makefile.frag.orig
++++ ./pear/Makefile.frag
+@@ -2,8 +2,11 @@
+
+ peardir=$(PEAR_INSTALLDIR)
+
++# help the built php to find xml extension so we can install pear
++PEAR_INSTALL_XML_FLAGS = -d extension_dir="$(top_builddir)/modules" -d extension=xml.so
++
+ # Skip all php.ini files altogether
+-PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=1803 -dmemory_limit=-1 -ddetect_unicode=0
++PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=1803 -dmemory_limit=-1 -ddetect_unicode=0 $(PEAR_INSTALL_XML_FLAGS)
+
+ WGET = `which wget 2>/dev/null`
+ FETCH = `which fetch 2>/dev/null`