aboutsummaryrefslogtreecommitdiffstats
path: root/main/pllua
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-04 23:04:29 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-04 23:30:08 +0100
commitef609351a6b52c7edab28bd0b549e1170fbf1723 (patch)
treeeee425280eb6e58c5053247840ad6cc370488fae /main/pllua
parentac8e7d8621c1cdb4ae9a99227aab0ed5bd6ecbad (diff)
downloadaports-ef609351a6b52c7edab28bd0b549e1170fbf1723.tar.bz2
aports-ef609351a6b52c7edab28bd0b549e1170fbf1723.tar.xz
main/pllua: build against LuaJIT
Diffstat (limited to 'main/pllua')
-rw-r--r--main/pllua/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/main/pllua/APKBUILD b/main/pllua/APKBUILD
index 03be248d2e..d354ac8bae 100644
--- a/main/pllua/APKBUILD
+++ b/main/pllua/APKBUILD
@@ -5,10 +5,10 @@ pkgver=1.1.0
pkgrel=0
pkgdesc="Procedural language for PostgreSQL using Lua"
url="https://github.com/pllua/pllua"
-arch="all"
+arch="all !s390x" # s390x: luajit is not avail
license="GPL"
depends="postgresql"
-makedepends="postgresql-dev lua-dev"
+makedepends="postgresql-dev luajit-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/pllua/$pkgname/archive/v$pkgver.tar.gz
fix-on-32bit.patch
fix-postgres10.patch"
@@ -17,7 +17,9 @@ options="!check" # tests require running PostgreSQL
build() {
cd "$builddir"
- LUA_INCDIR=/usr/include LUALIB='-llua' USE_PGXS=1 make
+ make LUA_INCDIR=$(pkgconf --variable=includedir luajit) \
+ LUALIB=$(pkgconf --libs luajit) \
+ USE_PGXS=1
}
package() {