aboutsummaryrefslogtreecommitdiffstats
path: root/main/pm-utils
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-10-11 14:20:58 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-10-11 14:20:58 +0000
commit68c4c422930524a2f3162b70c7ae5f6d2691e268 (patch)
treec992ea2b3cf7e69db7478f43cf5b2e82ab865ecf /main/pm-utils
parented75b2706da9e864a3a81a4c99507c243ac4c674 (diff)
downloadaports-68c4c422930524a2f3162b70c7ae5f6d2691e268.tar.bz2
aports-68c4c422930524a2f3162b70c7ae5f6d2691e268.tar.xz
testing/pm-utils: move to main
Diffstat (limited to 'main/pm-utils')
-rw-r--r--main/pm-utils/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/main/pm-utils/APKBUILD b/main/pm-utils/APKBUILD
new file mode 100644
index 0000000000..1afed83ebd
--- /dev/null
+++ b/main/pm-utils/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=pm-utils
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="A small collection of scripts that handle suspend and resume on behalf of HAL"
+url="http://pm-utils.freedesktop.org"
+arch="all"
+license="GPL"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://pm-utils.freedesktop.org/releases/$pkgname-$pkgver.tar.gz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="1742a556089c36c3a89eb1b957da5a60 pm-utils-1.4.1.tar.gz"