aboutsummaryrefslogtreecommitdiffstats
path: root/main/pound
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 11:20:01 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-07 19:10:57 +0000
commitbfcf09e5597b2b7129f429899c9898356d394ce8 (patch)
treec7ce5aba69edda1e4f2cf994e87bc0ac5d2ba54d /main/pound
parent4cdbde1056ec3ead3dd96dd1208d1caac54a3206 (diff)
downloadaports-bfcf09e5597b2b7129f429899c9898356d394ce8.tar.bz2
aports-bfcf09e5597b2b7129f429899c9898356d394ce8.tar.xz
main/pound: modernize abuild
Diffstat (limited to 'main/pound')
-rw-r--r--main/pound/APKBUILD27
1 files changed, 8 insertions, 19 deletions
diff --git a/main/pound/APKBUILD b/main/pound/APKBUILD
index 6805edb261..a86825e4fa 100644
--- a/main/pound/APKBUILD
+++ b/main/pound/APKBUILD
@@ -13,15 +13,10 @@ source="http://www.apsis.ch/$pkgname/Pound-$pkgver.tgz
pound.cfg
$pkgname.initd"
-_builddir="$srcdir"/Pound-$pkgver
+builddir="$srcdir"/Pound-$pkgver
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- update_config_sub || return 1
+ default_prepare
+ update_config_sub
}
build() {
@@ -32,24 +27,18 @@ build() {
--prefix=/usr \
--sysconfdir=/etc/pound \
--with-owner=root \
- --with-group=root \
- || return 1
- make || return 1
+ --with-group=root
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
install -d "$pkgdir"/usr/sbin
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/pound.initd "$pkgdir"/etc/init.d/pound
install -Dm644 "$srcdir"/pound.cfg "$pkgdir"/etc/pound.cfg
}
-md5sums="ec8298aa3e4aee3ffbecdc0639d7f14a Pound-2.7.tgz
-736b12a47acbb7fc2802ed7f51e959d0 pound.cfg
-40527cd0c8433bef8f10cfe8a0b0d8b2 pound.initd"
-sha256sums="cdfbf5a7e8dc8fbbe0d6c1e83cd3bd3f2472160aac65684bb01ef661c626a8e4 Pound-2.7.tgz
-e13a68731464472f4fc1f86c688b3697fe304e77811f01a0c9fa9fe186cc047c pound.cfg
-a656a008fbe672cc59b0d30f37ca55ed72042c5cdc7d5f13554e82d072c346ea pound.initd"
+
sha512sums="3edfb948715ff7e38b7665cc083eb5619daf4c2ddda4efcffffa2bcf5d8c1ee158fa5275b16bbaea4cf51bf3f8c022ba2197d5f67d57732404a448ae00e62aa1 Pound-2.7.tgz
9471e5abe3e0ee83165ed01a7081a4d14075c6c21b9f9d7c3fb239aa78c38eae74394a7c7e7e7753d218a7ce5cae388823570d19b702a829baa93e949a8946b8 pound.cfg
cd014677ef7e724d5bd0a101436d0269d2fc18b4cd90ff71eaa690967754d3e4bfe5d0a439099967487b6256121ccc734b01880d96dff50d28242829715e7776 pound.initd"