aboutsummaryrefslogtreecommitdiffstats
path: root/main/protobuf-c
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-10-26 13:21:08 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-10-27 13:18:57 +0000
commitcddbccc06a6b2d856fc57d2d5af71d28443bcab4 (patch)
tree5e416d986598a16f0c26a49fd42ddd9b99556d15 /main/protobuf-c
parente561a0805016b48dbbf772bb2e82f308d07ad2ba (diff)
downloadaports-cddbccc06a6b2d856fc57d2d5af71d28443bcab4.tar.bz2
aports-cddbccc06a6b2d856fc57d2d5af71d28443bcab4.tar.xz
main/protobuf-c: modernize
Diffstat (limited to 'main/protobuf-c')
-rw-r--r--main/protobuf-c/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/main/protobuf-c/APKBUILD b/main/protobuf-c/APKBUILD
index 491b45ae57..0ffa5af075 100644
--- a/main/protobuf-c/APKBUILD
+++ b/main/protobuf-c/APKBUILD
@@ -1,7 +1,8 @@
+# Contributor: TBK <alpin@jjtc.eu>
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=protobuf-c
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="C bindings for Google's Protocol Buffers"
url="https://github.com/protobuf-c/protobuf-c/wiki"
arch="all"
@@ -12,29 +13,30 @@ makedepends="$depends_dev protobuf-dev"
install=
subpackages="$pkgname-dev"
source="https://github.com/protobuf-c/protobuf-c/releases/download/v$pkgver/protobuf-c-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- return 0
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- || return 1
+ --infodir=/usr/share/info
# parallel build issue:
# https://github.com/protobuf-c/protobuf-c/issues/156
- make t/test-full.pb.h && make || return 1
+ make t/test-full.pb.h && make
+}
+
+check() {
+ cd "$builddir"
+
+ make check
}
package() {
- cd "$_builddir"
+ cd "$builddir"
+
make DESTDIR="$pkgdir" install
}