aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-requests-oauthlib
diff options
context:
space:
mode:
authorPeter Bui <pnutzh4x0r@gmail.com>2015-07-20 23:55:01 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-21 06:10:51 +0000
commit6a0bb4f8ce4967ce039f312f5c7a8a8351783b4f (patch)
tree23447dfcfd6864b3b3d738be1979aff6a841043a /main/py-requests-oauthlib
parent2b928b1929e268783af39b79119739caefe38e88 (diff)
downloadaports-6a0bb4f8ce4967ce039f312f5c7a8a8351783b4f.tar.bz2
aports-6a0bb4f8ce4967ce039f312f5c7a8a8351783b4f.tar.xz
main/py-requests-oauthlib: move and rename from testing
Diffstat (limited to 'main/py-requests-oauthlib')
-rw-r--r--main/py-requests-oauthlib/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/py-requests-oauthlib/APKBUILD b/main/py-requests-oauthlib/APKBUILD
new file mode 100644
index 0000000000..d9997402f8
--- /dev/null
+++ b/main/py-requests-oauthlib/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Peter Bui <pnutzh4x0r@gmail.com>
+pkgname=py-requests-oauthlib
+_pkgname=requests-oauthlib
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="First-class OAuth library support for Requests"
+url="https://pypi.python.org/pypi/requests-oauthlib"
+arch="noarch"
+license="GPL"
+depends="python py-requests py-oauthlib"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="4e5125f249580ae4f815d7291f505124 requests-oauthlib-0.4.1.tar.gz"
+sha256sums="c6d2550c4fefc2a03d7422caf61e72ca7827854e0deefe201deb34a91527d88e requests-oauthlib-0.4.1.tar.gz"
+sha512sums="ebe3f891e4ca4cfd36a704ac711041390bb1b1d11d7c66473159183e5479053c7f515f4bd64d6969166258d1960863cd6427bf42ccd30d08baad90b388e535de requests-oauthlib-0.4.1.tar.gz"