aboutsummaryrefslogtreecommitdiffstats
path: root/main/python3
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-21 13:25:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-21 14:53:47 +0000
commit07cedb3c4b6880f48a5bce5f3fef0e7d1657b735 (patch)
treecaf911d1ee90250cd79855f30454ce7bcfd22c21 /main/python3
parente716900f0d42e6b02b166c161c0a5f4c8ef77775 (diff)
downloadaports-07cedb3c4b6880f48a5bce5f3fef0e7d1657b735.tar.bz2
aports-07cedb3c4b6880f48a5bce5f3fef0e7d1657b735.tar.xz
main/python3: fix conflict with python3-tkinter
python3-tkinter provides tkinter and idle so remove those from this package
Diffstat (limited to 'main/python3')
-rw-r--r--main/python3/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index bc812ba54f..8163de32b5 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -5,7 +5,7 @@ pkgname=python3
# the python2-tkinter's pkgver needs to be synchronized with this.
pkgver=3.6.3
_basever="${pkgver%.*}"
-pkgrel=8
+pkgrel=9
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -109,6 +109,9 @@ package() {
cd "$builddir"
make -j1 DESTDIR="$pkgdir" EXTRA_CFLAGS="$CFLAGS" install maninstall
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ # those are provided by python3-tkinter
+ rm -r "$pkgdir"/usr/bin/idle* "$pkgdir"/usr/lib/python*/idlelib \
+ "$pkgdir"/usr/lib/python*/tkinter
}
dev() {