aboutsummaryrefslogtreecommitdiffstats
path: root/main/rt4
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-05-02 23:23:37 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-03 15:02:21 +0000
commit22993195fba12519aafa7705421c79cd2dec02b2 (patch)
tree4224c0dfbd950b663f99cac3c43e677c6de42542 /main/rt4
parent6fe8aad53ef0b902e1449a4c6afb2d5f53448759 (diff)
downloadaports-22993195fba12519aafa7705421c79cd2dec02b2.tar.bz2
aports-22993195fba12519aafa7705421c79cd2dec02b2.tar.xz
main/rt4: fix source URL and do some minor improvements
Diffstat (limited to 'main/rt4')
-rw-r--r--main/rt4/APKBUILD86
1 files changed, 40 insertions, 46 deletions
diff --git a/main/rt4/APKBUILD b/main/rt4/APKBUILD
index f247642f1e..ccef1df24d 100644
--- a/main/rt4/APKBUILD
+++ b/main/rt4/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rt4
pkgver=4.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Request Tracker - issue and bug tracker"
pkgusers="rt4"
pkggroups="rt4"
@@ -102,61 +102,54 @@ depends="perl
ttf-droid
"
-makedepends="$depends autoconf"
+makedepends="autoconf"
install="$pkgname.pre-install $pkgname.pre-upgrade"
-subpackages=""
-source="http://www.bestpractical.com/pub/rt/release/rt-$pkgver.tar.gz
+source="https://download.bestpractical.com/pub/rt/release/rt-$pkgver.tar.gz
0001-email-allow-envelope-from-overriding-from-templates.patch
rt-varpath.patch
rt-autoconf-version.patch
"
+builddir="$srcdir"/rt-$pkgver
-_builddir="$srcdir"/rt-$pkgver
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare || return 1 # apply patches
sed -i -e 's_$RT::BasePath/share/fonts/_/usr/share/fonts/TTF/_g' \
- "$_builddir"/etc/RT_Config.pm*
+ "$builddir"/etc/RT_Config.pm* || return 1
- cat <<'EOF' >> config.layout
-# Alpine directory layout.
-<Layout Alpine>
- prefix: /usr
- exec_prefix: ${prefix}
- bindir: ${exec_prefix}/bin
- sbindir: ${exec_prefix}/sbin
- sysconfdir: /etc/rt4
- mandir: ${prefix}/share/man
- plugindir: ${prefix}/lib/rt4/plugins
- libdir: ${prefix}/lib/rt4/
- datadir: ${prefix}/share/rt4
- htmldir: ${datadir}/html
- fontdir: ${datadir}/fonts
- lexdir: ${datadir}/po
- staticdir: ${datadir}/static
- manualdir: ${datadir}/doc
- localstatedir: /var
- logfiledir: ${localstatedir}/log
- masonstatedir: ${localstatedir}/cache/mason_data
- sessionstatedir: ${localstatedir}/cache/session_data
- customdir: ${prefix}/local
- custometcdir: ${customdir}/etc
- customhtmldir: ${customdir}/html
- customlexdir: ${customdir}/po
- customlibdir: ${customdir}/lib
- customplugindir: ${customdir}/plugins
-</Layout>
-EOF
+ cat <<-'EOF' >> config.layout
+ # Alpine directory layout.
+ <Layout Alpine>
+ prefix: /usr
+ exec_prefix: ${prefix}
+ bindir: ${exec_prefix}/bin
+ sbindir: ${exec_prefix}/sbin
+ sysconfdir: /etc/rt4
+ mandir: ${prefix}/share/man
+ plugindir: ${prefix}/lib/rt4/plugins
+ libdir: ${prefix}/lib/rt4/
+ datadir: ${prefix}/share/rt4
+ htmldir: ${datadir}/html
+ fontdir: ${datadir}/fonts
+ lexdir: ${datadir}/po
+ staticdir: ${datadir}/static
+ manualdir: ${datadir}/doc
+ localstatedir: /var
+ logfiledir: ${localstatedir}/log
+ masonstatedir: ${localstatedir}/cache/mason_data
+ sessionstatedir: ${localstatedir}/cache/session_data
+ customdir: ${prefix}/local
+ custometcdir: ${customdir}/etc
+ customhtmldir: ${customdir}/html
+ customlexdir: ${customdir}/po
+ customlibdir: ${customdir}/lib
+ customplugindir: ${customdir}/plugins
+ </Layout>
+ EOF
}
build() {
- cd "$_builddir"
+ cd "$builddir"
autoconf && ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -171,9 +164,10 @@ build() {
}
package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" \
- install || return 1
+ cd "$builddir"
+
+ make -j1 DESTDIR="$pkgdir" install || return 1
+
# delete the droid fonts as we get them from ttf-droid
rm -rf "$pkgdir"/usr/share/rt4/fonts/ \
"$pkgdir"/usr/local