aboutsummaryrefslogtreecommitdiffstats
path: root/main/sdl_image
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /main/sdl_image
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'main/sdl_image')
-rw-r--r--main/sdl_image/APKBUILD48
-rw-r--r--main/sdl_image/CVE-2019-13616.patch16
2 files changed, 0 insertions, 64 deletions
diff --git a/main/sdl_image/APKBUILD b/main/sdl_image/APKBUILD
deleted file mode 100644
index dbb3d172f5..0000000000
--- a/main/sdl_image/APKBUILD
+++ /dev/null
@@ -1,48 +0,0 @@
-# Contributor: Carlo Landmeter
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=sdl_image
-pkgver=1.2.12
-pkgrel=5
-pkgdesc="A simple library to load images of various formats as SDL surfaces"
-url="http://www.libsdl.org/projects/SDL_image/"
-arch="all"
-options="!check" # No test suite.
-license="Zlib"
-depends=""
-makedepends="sdl-dev libpng-dev libjpeg-turbo-dev libwebp-dev tiff-dev zlib-dev"
-install=""
-subpackages="$pkgname-dev"
-source="https://www.libsdl.org/projects/SDL_image/release/SDL_image-${pkgver}.tar.gz
- CVE-2019-13616.patch
- "
-
-# secfixes:
-# 1.2.12-r5:
-# - CVE-2019-13616
-
-builddir="$srcdir"/SDL_image-$pkgver
-prepare() {
- cd "$builddir"
- update_config_sub
- default_prepare
-}
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="0e71b280abc2a7f15755e4480a3c1b52d41f9f8b0c9216a6f5bd9fc0e939456fb5d6c10419e1d1904785783f9a1891ead278c03e88b0466fecc6871c3ca40136 SDL_image-1.2.12.tar.gz
-0ae144202435ad35e5ff6ae6b73592cd8ef68dba2704e09ba22f2b9e9d98f547f2ead28327be0594897f2165d2bf5c26f07e8ef72760527e8d9e4e593e8e5f60 CVE-2019-13616.patch"
diff --git a/main/sdl_image/CVE-2019-13616.patch b/main/sdl_image/CVE-2019-13616.patch
deleted file mode 100644
index f2ed7c6aa0..0000000000
--- a/main/sdl_image/CVE-2019-13616.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/IMG_bmp.c b/IMG_bmp.c
-index b3c7580..bfadd45 100644
---- a/IMG_bmp.c
-+++ b/IMG_bmp.c
-@@ -272,6 +272,11 @@ static SDL_Surface *LoadBMP_RW (SDL_RWops *src, int freesrc)
- biClrUsed = SDL_ReadLE32(src);
- biClrImportant = SDL_ReadLE32(src);
- }
-+ if (biWidth <= 0 || biHeight == 0) {
-+ IMG_SetError("BMP file with bad dimensions (%dx%d)", biWidth, biHeight);
-+ was_error = SDL_TRUE;
-+ goto done;
-+ }
- if (biHeight < 0) {
- topDown = SDL_TRUE;
- biHeight = -biHeight;