aboutsummaryrefslogtreecommitdiffstats
path: root/main/smstools/makefile.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-22 11:18:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 11:18:42 +0000
commitda5cd3f343a44c7c04da89d5fc061596a1940ec5 (patch)
tree68000c95dc1d81ca254448c9c8ce76f1631a12c0 /main/smstools/makefile.patch
parentb27b9388a25701c6546c6d4d3acfb0aeacd82df8 (diff)
downloadaports-da5cd3f343a44c7c04da89d5fc061596a1940ec5.tar.bz2
aports-da5cd3f343a44c7c04da89d5fc061596a1940ec5.tar.xz
main/smstool: fix makefile
Diffstat (limited to 'main/smstools/makefile.patch')
-rw-r--r--main/smstools/makefile.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/smstools/makefile.patch b/main/smstools/makefile.patch
new file mode 100644
index 0000000000..459e5d64a8
--- /dev/null
+++ b/main/smstools/makefile.patch
@@ -0,0 +1,42 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -7,7 +7,7 @@
+ VERSION=$(shell grep package_version src/version.h | cut -f2)
+
+ compile:
+- cd src && $(MAKE) -$(MAKEFLAGS)
++ cd src && $(MAKE)
+
+ install: compile
+ ./install.sh $(BINDIR)
+@@ -16,7 +16,7 @@
+ ./uninstall.sh $(BINDIR)
+
+ clean:
+- cd src && $(MAKE) -$(MAKEFLAGS) clean
++ cd src && $(MAKE) clean
+
+ package: compile clean
+ ./package.sh
+--- ./src/Makefile.orig
++++ ./src/Makefile
+@@ -37,15 +37,15 @@
+ # Use the following only on GNU/Linux and only if you need ps listing like "smsd: MAINPROCESS" and "smsd: GSM1"
+ # CFLAGS += -D USE_LINUX_PS_TRICK
+
+-all: smsd
+-
+-smsd: smsd.c extras.o locking.o cfgfile.o logging.o alarm.o smsd_cfg.o charset.o stats.o blacklist.o whitelist.o modeminit.o pdu.o
+-
+ ifneq (,$(findstring SOLARIS,$(CFLAGS)))
+ ifeq (,$(findstring DISABLE_INET_SOCKET,$(CFLAGS)))
+ override LFLAGS += -lsocket -lnsl
+ endif
+ endif
++
++all: smsd
++
++smsd: smsd.c extras.o locking.o cfgfile.o logging.o alarm.o smsd_cfg.o charset.o stats.o blacklist.o whitelist.o modeminit.o pdu.o
+
+ ifneq (,$(findstring NOSTATS,$(CFLAGS)))
+ $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS)