aboutsummaryrefslogtreecommitdiffstats
path: root/main/spawn-fcgi/spawn-fcgi.confd
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-02-16 03:43:10 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-06-06 13:54:57 +0000
commit3fcde78eff6ea7d17dabe7fee352d39147b8d602 (patch)
tree7a0e4f080c37af60a887c226585779dada9b6b23 /main/spawn-fcgi/spawn-fcgi.confd
parentb7a326232d701d67e71ec1b4d4eb9e4b89b9507e (diff)
downloadaports-3fcde78eff6ea7d17dabe7fee352d39147b8d602.tar.bz2
aports-3fcde78eff6ea7d17dabe7fee352d39147b8d602.tar.xz
main/spawn-fcgi: fix dealing with unix sockets
fix collision when both socket and tcp_port are set up cleanups in APKBUILD and confd
Diffstat (limited to 'main/spawn-fcgi/spawn-fcgi.confd')
-rw-r--r--main/spawn-fcgi/spawn-fcgi.confd22
1 files changed, 11 insertions, 11 deletions
diff --git a/main/spawn-fcgi/spawn-fcgi.confd b/main/spawn-fcgi/spawn-fcgi.confd
index b5a6ed5028..62712fb36c 100644
--- a/main/spawn-fcgi/spawn-fcgi.confd
+++ b/main/spawn-fcgi/spawn-fcgi.confd
@@ -14,45 +14,45 @@
# Leave empty to use an IP socket (default). See below. Enabling this,
# disables the IP socket.
#
-FCGI_SOCKET=
+#FCGI_SOCKET=
# When using FCGI_PORT, connections will only be accepted from the following
# address. The default is 127.0.0.1. Use 0.0.0.0 to bind to all addresses.
#
-FCGI_ADDRESS=127.0.0.1
+#FCGI_ADDRESS=
# The port specified by FCGI_PORT is the port used
# by the first child process. If this is set to 1234 then subsequent child
# processes will use 1235, 1236, etc.
+# The default is 1234 if FCGI_SOCKET is not set
#
-FCGI_PORT=1234
+#FCGI_PORT=
# The path to your FastCGI application. These sometimes carry the .fcgi
# extension but not always. For PHP, you should usually point this to
# /usr/bin/php-cgi.
#
-#FCGI_PROGRAM=/usr/bin/php-cgi
-FCGI_PROGRAM=
+#FCGI_PROGRAM=
# The number of child processes to spawn. The default is 1.
#
-FCGI_CHILDREN=1
+#FCGI_CHILDREN=
# If you want to run your application inside a chroot then specify the
# directory here. Leave this blank otherwise.
#
-FCGI_CHROOT=
+#FCGI_CHROOT=
# If you want to run your application from a specific directiory specify
# it here. Leave this blank otherwise.
#
-FCGI_CHDIR=
+#FCGI_CHDIR=
# The user and group to run your application as. If you do not specify these,
# the application will be run as root:root.
#
-FCGI_USER=
-FCGI_GROUP=
+#FCGI_USER=
+#FCGI_GROUP=
# Additional options you might want to pass to spawn-fcgi
#
@@ -61,7 +61,7 @@ FCGI_GROUP=
# If your application requires additional environment variables, you may
# specify them here. See PHP example below.
#
-ALLOWED_ENV="PATH"
+#ALLOWED_ENV="PATH"
# PHP ONLY :: These two options are specific to PHP. The first is the number
# of child processes to spawn. The second is the number of requests to be