aboutsummaryrefslogtreecommitdiffstats
path: root/main/spice
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-13 08:46:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-13 09:01:43 +0000
commita887645297d9345a54253c577ef27a9998557145 (patch)
tree5747839aa7b526855e16e855766d8e28baa61d81 /main/spice
parenteda0077e74e2440e671b762484586ab769a70f12 (diff)
downloadaports-a887645297d9345a54253c577ef27a9998557145.tar.bz2
aports-a887645297d9345a54253c577ef27a9998557145.tar.xz
main/spice: security upgrade to 0.12.6
Diffstat (limited to 'main/spice')
-rw-r--r--main/spice/APKBUILD29
-rw-r--r--main/spice/cstdarg.patch10
-rw-r--r--main/spice/fix-non-x86-build.patch36
3 files changed, 7 insertions, 68 deletions
diff --git a/main/spice/APKBUILD b/main/spice/APKBUILD
index e0e4b0b372..3c8d885321 100644
--- a/main/spice/APKBUILD
+++ b/main/spice/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice
-pkgver=0.12.5
-pkgrel=2
+pkgver=0.12.6
+pkgrel=0
pkgdesc="Implements the SPICE protocol"
url="http://www.spice-space.org/"
arch="all"
@@ -11,12 +11,10 @@ depends=""
depends_dev="spice-protocol pixman-dev celt051-dev openssl-dev libxinerama-dev"
makedepends="$depends_dev alsa-lib-dev libjpeg-turbo-dev libxrandr-dev
cyrus-sasl-dev libxfixes-dev python-dev bash cegui06-dev py-parsing
- glib-dev"
+ py-six glib-dev"
install=""
-subpackages="$pkgname-dev $pkgname-server $pkgname-client"
+subpackages="$pkgname-dev $pkgname-server"
source="http://www.spice-space.org/download/releases/spice-$pkgver.tar.bz2
- cstdarg.patch
- fix-non-x86-build.patch
"
_builddir="$srcdir"/spice-$pkgver
@@ -45,7 +43,6 @@ build() {
--disable-smartcard \
|| return 1
make -C spice-common WARN_CFLAGS='' || return 1
- make -C client WARN_CFLAGS='' || return 1
make WARN_CFLAGS='' || return 1
}
@@ -60,18 +57,6 @@ server() {
mv "$pkgdir"/usr/lib/*server.so.* "$subpkgdir"/usr/lib/
}
-client() {
- pkgdesc="SPICE client"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/spicec "$subpkgdir"/usr/bin/
-}
-
-md5sums="1256286214fe402703c0a01bd3a85319 spice-0.12.5.tar.bz2
-3e61fdc18bf201a2b54b332fdbe2912e cstdarg.patch
-cf73b5f5ee618b9de82a6025b4d4cfff fix-non-x86-build.patch"
-sha256sums="4209a20d8f67cb99a8a6ac499cfe79a18d4ca226360457954a223d6795c2f581 spice-0.12.5.tar.bz2
-bc2219f68ed701e74a02c5196c934bb3e6fbf5813005f39e41e911668e0e622c cstdarg.patch
-e7d13db986ef482c9788f7c90eb3d7de11d662536a21c9812b332da79659fb6a fix-non-x86-build.patch"
-sha512sums="1501c913ba3b1856444536a9bfda7a2138a96088f940b483e963df342b91deb945d77bfb3c83ebddfcd7c3008695c0dd7df30ff9fd8502cbbcac1c610a273572 spice-0.12.5.tar.bz2
-040f4104d9658465cb2ffa72101f958341497898d86ee82bdf31bd65e5f3497822be4b9b3e9eca2a9b965385481190a2fb4ca5fb26b89391ab1598fc23d300c9 cstdarg.patch
-0420d8e18fd900edbdbe7d100ca2b35b0e8a3466cce6846fd44ecba82da942139fab07111f9f6e7b49d11760028f19f17b75a56f0b7a52651450ae03695e0a90 fix-non-x86-build.patch"
+md5sums="605a8c8ea80bc95076c4b3539c6dd026 spice-0.12.6.tar.bz2"
+sha256sums="f148ea30135bf80a4f465ce723a1cd6d4ccb34c098b6298a020b378ace8569b6 spice-0.12.6.tar.bz2"
+sha512sums="877d9c447a09055c61db7839ae1a2bbd97ab1178d8fd30fff83883064f8a2f269479649e696732095833ed3fda2d0cc0cbe2a420decb89d36d2cf2f18ad9a3db spice-0.12.6.tar.bz2"
diff --git a/main/spice/cstdarg.patch b/main/spice/cstdarg.patch
deleted file mode 100644
index 7a16dc579c..0000000000
--- a/main/spice/cstdarg.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./client/common.h.orig
-+++ ./client/common.h
-@@ -39,6 +39,7 @@
- #include <exception>
- #include <list>
- #include <string.h>
-+#include <cstdarg>
-
- #ifdef WIN32
- #ifdef __GNUC__
diff --git a/main/spice/fix-non-x86-build.patch b/main/spice/fix-non-x86-build.patch
deleted file mode 100644
index 04a560b127..0000000000
--- a/main/spice/fix-non-x86-build.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-See also: https://bugs.freedesktop.org/show_bug.cgi?id=86997
-
-diff -ru spice-0.12.5.orig/client/utils.h spice-0.12.5/client/utils.h
---- spice-0.12.5.orig/client/utils.h 2014-12-04 13:45:13.843329437 -0200
-+++ spice-0.12.5/client/utils.h 2014-12-04 13:44:58.449995951 -0200
-@@ -50,9 +50,13 @@
- throw Exception(exption_string, err); \
- }
-
-+#if defined(__i386__) || defined(__x86_64__)
- #define SPICE_BREAKPOINT() do{ \
- __asm__ __volatile__ ("int $03"); \
- }while(0)
-+#else
-+#define SPICE_BREAKPOINT() do {} while (0)
-+#endif
-
- template <class T>
- class AutoRef {
-diff -ru spice-0.12.5.orig/spice-common/spice-protocol/spice/barrier.h spice-0.12.5/spice-common/spice-protocol/spice/barrier.h
---- spice-0.12.5.orig/spice-common/spice-protocol/spice/barrier.h 2013-12-10 20:42:54.000000000 -0200
-+++ spice-0.12.5/spice-common/spice-protocol/spice/barrier.h 2014-12-04 13:45:54.593329844 -0200
-@@ -34,12 +34,7 @@
-
- #ifdef __GNUC__
-
--#ifdef __i386__
--#define spice_mb() __asm__ __volatile__ ("lock; addl $0,0(%%esp)": : :"memory")
--#else
--//mfence
--#define spice_mb() __asm__ __volatile__ ("lock; addl $0,0(%%rsp)": : :"memory")
--#endif
-+#define spice_mb() __sync_synchronize()
-
- #else
-