aboutsummaryrefslogtreecommitdiffstats
path: root/main/task
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-17 09:39:52 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-17 09:39:52 +0000
commitd78b46d25e88eaef297d0d4ed215721ad9c8d116 (patch)
tree7098891fc8cd7ae7c6cfe259f98a80953f58e3e0 /main/task
parentc1a9ec431a31483c3c4527fe824dd21b8339bbf5 (diff)
downloadaports-d78b46d25e88eaef297d0d4ed215721ad9c8d116.tar.bz2
aports-d78b46d25e88eaef297d0d4ed215721ad9c8d116.tar.xz
main/task: fix musl build
Diffstat (limited to 'main/task')
-rw-r--r--main/task/APKBUILD15
-rw-r--r--main/task/musl-fix.patch30
2 files changed, 40 insertions, 5 deletions
diff --git a/main/task/APKBUILD b/main/task/APKBUILD
index adc6d2103f..da88beaba3 100644
--- a/main/task/APKBUILD
+++ b/main/task/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=task
pkgver=2.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="A command-line to do list manager"
url="http://taskwarrior.org"
arch="all"
@@ -11,7 +11,9 @@ depends_dev=""
makedepends="$depends_dev cmake util-linux-dev"
install=""
subpackages="$pkgname-doc"
-source="http://taskwarrior.org/download/task-$pkgver.tar.gz"
+source="http://taskwarrior.org/download/task-$pkgver.tar.gz
+ musl-fix.patch
+ "
_builddir="$srcdir"/task-$pkgver
prepare() {
@@ -38,6 +40,9 @@ package() {
make install DESTDIR="$pkgdir"
}
-md5sums="eb5af01b51b90e01b574464a5d11d4e9 task-2.2.0.tar.gz"
-sha256sums="39e25dd285e6bc8474337a5868cb2ec55675978fa1f08c802e6da58b4181ee14 task-2.2.0.tar.gz"
-sha512sums="16ff1ccd037d62fc99ea0a31647714d3ccf8a90948b67d845d55e08e4bf49bb6a7f69f7464f485093abeff0672f17dc5f6d4efd96d2e447316975d185082f862 task-2.2.0.tar.gz"
+md5sums="eb5af01b51b90e01b574464a5d11d4e9 task-2.2.0.tar.gz
+6bb238053ac82c5561534fba2c2b66b1 musl-fix.patch"
+sha256sums="39e25dd285e6bc8474337a5868cb2ec55675978fa1f08c802e6da58b4181ee14 task-2.2.0.tar.gz
+b01d952072f823f30c860aca467be24de1d4bbd901dbcd4d9fd09a227bfdd4a9 musl-fix.patch"
+sha512sums="16ff1ccd037d62fc99ea0a31647714d3ccf8a90948b67d845d55e08e4bf49bb6a7f69f7464f485093abeff0672f17dc5f6d4efd96d2e447316975d185082f862 task-2.2.0.tar.gz
+40a37810053e9720656b877cafc2fcb48cf1c867a89df0e4fd26f2e2dc4fd635fb8cab70bcc169c4a2b48480a90aef52594b9052479c168a1974fdcc7c7f495f musl-fix.patch"
diff --git a/main/task/musl-fix.patch b/main/task/musl-fix.patch
new file mode 100644
index 0000000000..91861ec2e8
--- /dev/null
+++ b/main/task/musl-fix.patch
@@ -0,0 +1,30 @@
+--- task-2.2.0.orig/src/Directory.cpp
++++ task-2.2.0/src/Directory.cpp
+@@ -34,10 +34,7 @@
+ #include <string.h>
+ #include <Directory.h>
+ #include <cmake.h>
+-
+-#ifdef SOLARIS
+ #include <limits.h>
+-#endif
+
+ ////////////////////////////////////////////////////////////////////////////////
+ Directory::Directory ()
+--- task-2.2.0.orig/src/Path.cpp
++++ task-2.2.0/src/Path.cpp
+@@ -38,6 +38,14 @@
+ #include <Path.h>
+ #include <cmake.h>
+
++#ifndef GLOB_TILDE
++#define GLOB_TILDE 0
++#endif
++
++#ifndef GLOB_BRACE
++#define GLOB_BRACE 0
++#endif
++
+ ////////////////////////////////////////////////////////////////////////////////
+ std::ostream& operator<< (std::ostream& out, const Path& path)
+ {