aboutsummaryrefslogtreecommitdiffstats
path: root/main/tftp-hpa
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-30 07:11:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-30 07:11:56 +0000
commitb2d94aaa0d1ea342a38f542276b8afedff78f8ab (patch)
tree2778eaf706c2fab4131dcaf75b2cb306ea1cb9b1 /main/tftp-hpa
parentff21403a29341cc0a762ee7ea1afbd276889c5e3 (diff)
downloadaports-b2d94aaa0d1ea342a38f542276b8afedff78f8ab.tar.bz2
aports-b2d94aaa0d1ea342a38f542276b8afedff78f8ab.tar.xz
tftp-hpa: rename dir to match pkgname
Diffstat (limited to 'main/tftp-hpa')
-rw-r--r--main/tftp-hpa/APKBUILD33
-rw-r--r--main/tftp-hpa/in.tftpd.confd15
-rw-r--r--main/tftp-hpa/in.tftpd.initd21
3 files changed, 69 insertions, 0 deletions
diff --git a/main/tftp-hpa/APKBUILD b/main/tftp-hpa/APKBUILD
new file mode 100644
index 0000000000..02106e049a
--- /dev/null
+++ b/main/tftp-hpa/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=tftp-hpa
+pkgver=5.0
+pkgrel=2
+pkgdesc="Official tftp server"
+url="http://www.kernel.org/pub/software/network/tftp/"
+arch="all"
+license="BSD"
+depends=
+makedepends=
+subpackage="$pkgname-doc"
+source="http://www.kernel.org/pub/software/network/tftp/$pkgname-$pkgver.tar.gz
+ in.tftpd.initd
+ in.tftpd.confd
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man || return 1
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make INSTALLROOT="$pkgdir" install || return 1
+ install -d "$pkgdir"/var/tftpboot
+ install -Dm755 ../in.tftpd.initd "$pkgdir"/etc/init.d/in.tftpd
+ install -Dm755 ../in.tftpd.confd "$pkgdir"/etc/conf.d/in.tftpd
+}
+md5sums="1ae813a94670f0d8c294aafa9f5ecf65 tftp-hpa-5.0.tar.gz
+3430e0b0e42c3321689d2c87e73d0749 in.tftpd.initd
+914b43dd531176a8bb58fdb23d900fef in.tftpd.confd"
diff --git a/main/tftp-hpa/in.tftpd.confd b/main/tftp-hpa/in.tftpd.confd
new file mode 100644
index 0000000000..5d74ac15fa
--- /dev/null
+++ b/main/tftp-hpa/in.tftpd.confd
@@ -0,0 +1,15 @@
+# /etc/init.d/in.tftpd
+
+# Path to server files from
+# Depending on your application you may have to change this.
+INTFTPD_PATH="/var/tftpboot/"
+#INTFTPD_PATH="/var/tftp/"
+#INTFTPD_PATH="/tftpboot/"
+#INTFTPD_PATH="/tftproot/"
+
+# For more options, see in.tftpd(8)
+# -R 4096:32767 solves problems with ARC firmware, and obsoletes
+# the /proc/sys/net/ipv4/ip_local_port_range hack.
+# -s causes $INTFTPD_PATH to be the root of the TFTP tree.
+# -l is passed by the init script in addition to these options.
+INTFTPD_OPTS="-R 4096:32767 -s ${INTFTPD_PATH}"
diff --git a/main/tftp-hpa/in.tftpd.initd b/main/tftp-hpa/in.tftpd.initd
new file mode 100644
index 0000000000..c8657634bf
--- /dev/null
+++ b/main/tftp-hpa/in.tftpd.initd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/tftp-hpa/files/in.tftpd.rc6,v 1.2 2005/07/30 06:29:14 vapier Exp $
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting tftpd"
+ /usr/sbin/in.tftpd -l ${INTFTPD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tftpd"
+ start-stop-daemon --stop --exec /usr/sbin/in.tftpd
+ eend $?
+}