aboutsummaryrefslogtreecommitdiffstats
path: root/main/truecrypt/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-06-13 08:32:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-06-13 08:32:13 +0000
commit82b24148942203f7b504cb6d3c3ec2420739ce5b (patch)
tree1bef764f951c77cf30058586842ecdef8c9b9d3c /main/truecrypt/APKBUILD
parentf170b059fef49ebcaa2c0e6beaa9a136b41398bc (diff)
downloadaports-82b24148942203f7b504cb6d3c3ec2420739ce5b.tar.bz2
aports-82b24148942203f7b504cb6d3c3ec2420739ce5b.tar.xz
main/truecrypt: moved from testing and fix libdl underlinking
Diffstat (limited to 'main/truecrypt/APKBUILD')
-rw-r--r--main/truecrypt/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/main/truecrypt/APKBUILD b/main/truecrypt/APKBUILD
new file mode 100644
index 0000000000..b36ff8f841
--- /dev/null
+++ b/main/truecrypt/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=truecrypt
+pkgver=7.1
+pkgrel=2
+pkgdesc="crypto"
+url="http://www.truecrypt.org/"
+arch="all"
+license="AS-IS"
+depends="device-mapper"
+depends_dev=""
+makedepends="nasm fuse-dev wxgtk-dev"
+install=""
+subpackages=""
+source="ftp://ftp.archlinux.org/other/tc/truecrypt-${pkgver}.tar.gz
+ ftp://ftp.archlinux.org/other/tc/pkcs-2.20.tar.gz
+ truecrypt-arch-detection.patch
+ execstack-fix.patch
+ libdl.patch
+ truecrypt.desktop
+ "
+
+_builddir="$srcdir"/truecrypt-7.1-source
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make PKCS11_INC="${srcdir}/pkcs-2.20" VERBOSE=1 \
+ TC_EXTRA_CFLAGS="${CFLAGS}" \
+ TC_EXTRA_CXXFLAGS="${CXXFLAGS}" \
+ TC_EXTRA_LFLAGS="${LDFLAGS} -fno-PIE" \
+ NOSTRIP=1 \
+ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 Main/truecrypt "$pkgdir"/usr/bin/truecrypt || return 1
+ install -Dm644 "$srcdir"/truecrypt.desktop \
+ "$pkgdir"/usr/share/applications/truecrypt.desktop
+}
+
+md5sums="a8268630a870faff07af940f63fb29eb truecrypt-7.1.tar.gz
+ce6a707b79411e82e8e558aa03e764b0 pkcs-2.20.tar.gz
+00ea70fa8437de877b31b027ac2b4060 truecrypt-arch-detection.patch
+78e606e6582dacc3176d59ad4419b6bb execstack-fix.patch
+11d7a8d9b83012750f0161f6116a9af8 libdl.patch
+183b9bf04a943454d4e216130bcbac01 truecrypt.desktop"