aboutsummaryrefslogtreecommitdiffstats
path: root/main/unbound
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-05-02 20:32:00 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-05-02 20:59:20 +0200
commitcba505e540efe9e4bd1ab73d0c11d504d10ab44e (patch)
tree5b161441830f1754e275949e95b6ec96f76abc07 /main/unbound
parent786a3013fc7cc24afa4e978e413f223423260c25 (diff)
downloadaports-cba505e540efe9e4bd1ab73d0c11d504d10ab44e.tar.bz2
aports-cba505e540efe9e4bd1ab73d0c11d504d10ab44e.tar.xz
main/unbound: upgrade to 1.6.2, modernize APKBUILD
Diffstat (limited to 'main/unbound')
-rw-r--r--main/unbound/APKBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/main/unbound/APKBUILD b/main/unbound/APKBUILD
index 9fa2c70e33..601481a1ea 100644
--- a/main/unbound/APKBUILD
+++ b/main/unbound/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=unbound
-pkgver=1.6.1
-pkgrel=1
+pkgver=1.6.2
+pkgrel=0
pkgdesc="Unbound is a validating, recursive, and caching DNS resolver"
pkgusers="unbound"
pkggroups="unbound"
@@ -43,36 +43,31 @@ build() {
--disable-rpath \
--with-ssl \
--without-pythonmodule \
- --with-pyunbound \
- || return 1
+ --with-pyunbound
# do not link to libpython
sed -e '/^LIBS=/s/-lpython.*[[:space:]]/ /' \
- -i Makefile || return 1
+ -i Makefile
- make || return 1
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -D contrib/update-anchor.sh \
- "$pkgdir"/usr/share/$pkgname/update-anchor.sh \
- || return 1
+ "$pkgdir"/usr/share/$pkgname/update-anchor.sh
install -Dm755 "$srcdir"/update-unbound-root-hints \
- "$pkgdir"/etc/periodic/monthly/update-unbound-root-hints \
- || return 1
+ "$pkgdir"/etc/periodic/monthly/update-unbound-root-hints
install -m755 -D "$srcdir"/unbound.initd \
- "$pkgdir"/etc/init.d/unbound || return 1
- install -d -o unbound -g unbound "$pkgdir"/var/run/unbound || return 1
- install -m644 "$srcdir"/root.hints "$pkgdir"/etc/unbound/ || return 1
+ "$pkgdir"/etc/init.d/unbound
+ install -d -o unbound -g unbound "$pkgdir"/var/run/unbound
+ install -m644 "$srcdir"/root.hints "$pkgdir"/etc/unbound/
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
- for name in CREDITS Changelog FEATURES README TODO; do
- install -m644 "$builddir"/doc/$name \
- "$pkgdir"/usr/share/doc/$pkgname/$name || return 1
- done
+ install -m644 doc/CREDITS doc/Changelog doc/FEATURES \
+ doc/README doc/TODO "$pkgdir"/usr/share/doc/$pkgname/
}
libs() {
@@ -94,7 +89,7 @@ migrate() {
"$subpkgdir"/usr/bin/
}
-sha512sums="f232da1387e557a5a5812b393bb84d8e4f5f616006c60435dfd38f373594621a9050b649fe8497c031acffd697d28f888201847b1d156d3435a42b8db62f17c2 unbound-1.6.1.tar.gz
+sha512sums="ac7a4f7e6e857715bd047060ad27a36637ceaaea965fadea0124eb7d83a8bcffdf64723335ca4baf2428eefbd135909ed7a62530dc7f9fb68980726b4270a751 unbound-1.6.2.tar.gz
90faa8bf352132b63f6b33cd7d7cac164df331272568e7a442d92e021fcf727334f6e28c11ed211bcd3eb62aa606c110e4931b514fecf388d0fbea3810b7530a conf.patch
b16b7b15392c0d560718ee543f1eebc5617085fb30d61cddc20dd948bd8b1634ee5b2de1c9cb172a6c0d1c5bbaf98b6fd39816d39c72a43ff619455449e668ac update-unbound-root-hints
b26a13c1c88da9611a65705dc59f7233c5e0f6aced0d7d66c18536a969a2de627ca5d4bb55eedd81f2f040fa11bde48eaaeca2850f376e72e7a531678a259131 migrate-dnscache-to-unbound