aboutsummaryrefslogtreecommitdiffstats
path: root/main/wpa_supplicant
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-30 12:20:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-30 13:04:45 +0000
commit816500d4e1865c18645eb2f9cb9f54a7765edce3 (patch)
treeb7a3cc475ed2138fc4dceff9177e3eb183a84714 /main/wpa_supplicant
parent4891ee4b188d42a8c72f488df8a070d7cb79d2de (diff)
downloadaports-816500d4e1865c18645eb2f9cb9f54a7765edce3.tar.bz2
aports-816500d4e1865c18645eb2f9cb9f54a7765edce3.tar.xz
main/wpa_supplicant: rebuild against libnl3
Diffstat (limited to 'main/wpa_supplicant')
-rw-r--r--main/wpa_supplicant/APKBUILD23
-rw-r--r--main/wpa_supplicant/libnl3-includes.patch12
2 files changed, 29 insertions, 6 deletions
diff --git a/main/wpa_supplicant/APKBUILD b/main/wpa_supplicant/APKBUILD
index 43c8eefce3..4fb5a17afc 100644
--- a/main/wpa_supplicant/APKBUILD
+++ b/main/wpa_supplicant/APKBUILD
@@ -1,22 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wpa_supplicant
pkgver=1.0
-pkgrel=0
+pkgrel=1
pkgdesc="A utility providing key negotiation for WPA wireless networks"
url="http://hostap.epitest.fi/wpa_supplicant"
arch="all"
license="GPL"
subpackages="$pkgname-doc"
depends=
-makedepends="openssl-dev dbus-dev libnl-dev"
+makedepends="openssl-dev dbus-dev libnl3-dev"
source="http://hostap.epitest.fi/releases/$pkgname-$pkgver.tar.gz
wpa_supplicant.initd
wpa_supplicant.confd
+ libnl3-includes.patch
"
-_builddir="$srcdir"/$pkgname-$pkgver/$pkgname
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ for i in *.patch; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ cd "$_builddir"/wpa_supplicant
# Toolchain setup
echo "CC = ${CC:-gcc}" > .config
@@ -87,17 +95,19 @@ prepare() {
# Enable mitigation against certain attacks against TKIP
echo "CONFIG_DELAYED_MIC_ERROR_REPORT=y" >> .config
+
+ echo "CONFIG_LIBNL32=y" >> .config
}
build() {
- cd "$_builddir"
+ cd "$_builddir"/wpa_supplicant
make LIBDIR=/lib BINDIR=/sbin || return 1
# comment out the network={ } stansas in config
sed -i -e '/^network=/,/}/s/^/#/' wpa_supplicant.conf
}
package() {
- cd "$_builddir"
+ cd "$_builddir"/wpa_supplicant
make DESTDIR="$pkgdir" LIBDIR=/lib BINDIR=/sbin install || return 1
install -Dm644 wpa_supplicant.conf \
"$pkgdir"/etc/wpa_supplicant/wpa_supplicant.conf
@@ -124,4 +134,5 @@ package() {
}
md5sums="8650f6aa23646ef634402552d0669640 wpa_supplicant-1.0.tar.gz
55f853354f51ba947e4dd6ee2bb0d64a wpa_supplicant.initd
-bc117427f2c538439f3f1481a028ee06 wpa_supplicant.confd"
+bc117427f2c538439f3f1481a028ee06 wpa_supplicant.confd
+473fb6b77909ec5a50b6f4d91370e86b libnl3-includes.patch"
diff --git a/main/wpa_supplicant/libnl3-includes.patch b/main/wpa_supplicant/libnl3-includes.patch
new file mode 100644
index 0000000000..5d8903906a
--- /dev/null
+++ b/main/wpa_supplicant/libnl3-includes.patch
@@ -0,0 +1,12 @@
+diff -up wpa_supplicant-1.0-rc2/src/drivers/drivers.mak.foo wpa_supplicant-1.0-rc2/src/drivers/drivers.mak
+--- wpa_supplicant-1.0-rc2/src/drivers/drivers.mak.foo 2012-03-02 16:11:43.176448714 -0600
++++ wpa_supplicant-1.0-rc2/src/drivers/drivers.mak 2012-03-02 16:12:29.759866341 -0600
+@@ -48,7 +48,7 @@ NEED_RFKILL=y
+ ifdef CONFIG_LIBNL32
+ DRV_LIBS += -lnl-3
+ DRV_LIBS += -lnl-genl-3
+- DRV_CFLAGS += -DCONFIG_LIBNL20
++ DRV_CFLAGS += -DCONFIG_LIBNL20 `pkg-config --cflags libnl-3.0`
+ else
+ ifdef CONFIG_LIBNL_TINY
+ DRV_LIBS += -lnl-tiny