aboutsummaryrefslogtreecommitdiffstats
path: root/main/xf86-video-amdgpu
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 16:02:24 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-16 17:00:09 +0000
commitb77ae1ee38e93dbc0a5bf9d2d99633fce8b81e68 (patch)
tree37fbdc1676221eaa9ab7bc183d7de83b35a6bb77 /main/xf86-video-amdgpu
parent2c5123b65b79192075ab2718c286a798d640ffa2 (diff)
downloadaports-b77ae1ee38e93dbc0a5bf9d2d99633fce8b81e68.tar.bz2
aports-b77ae1ee38e93dbc0a5bf9d2d99633fce8b81e68.tar.xz
main/xf86-video-*: modernise, add check, add util-macros makedep
Diffstat (limited to 'main/xf86-video-amdgpu')
-rw-r--r--main/xf86-video-amdgpu/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/xf86-video-amdgpu/APKBUILD b/main/xf86-video-amdgpu/APKBUILD
index 2c3e973862..abe005254a 100644
--- a/main/xf86-video-amdgpu/APKBUILD
+++ b/main/xf86-video-amdgpu/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Linus Swälas <linus.swalas@borderless.se>
pkgname=xf86-video-amdgpu
pkgver=1.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="AMD Rx/HDxxxx video driver"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -11,7 +11,7 @@ options="!check"
depends="mesa-dri-ati"
makedepends="xorg-server-dev libxi-dev fontsproto randrproto
videoproto renderproto libdrm-dev xf86driproto glproto mesa-dev
- xineramaproto eudev-dev pixman-dev"
+ xineramaproto eudev-dev pixman-dev util-macros"
source="http://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
@@ -26,6 +26,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install