aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-11-10 01:59:46 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-11-10 02:00:11 +0000
commit13231070feabdb558068a82cdc71a72517f3aba4 (patch)
tree28fb2b4fc693ed744e6b600bb1fa8846115802c0 /main
parentae645df38f22ca429592394435c0039910516254 (diff)
downloadaports-13231070feabdb558068a82cdc71a72517f3aba4.tar.bz2
aports-13231070feabdb558068a82cdc71a72517f3aba4.tar.xz
main/python3: fix libressl build
Diffstat (limited to 'main')
-rw-r--r--main/python3/APKBUILD3
-rw-r--r--main/python3/libressl.patch10
2 files changed, 12 insertions, 1 deletions
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index 292faa5737..5eda229c0e 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -5,7 +5,7 @@ pkgname=python3
# the python2-tkinter's pkgver needs to be synchronized with this.
pkgver=3.6.3
_basever="${pkgver%.*}"
-pkgrel=6
+pkgrel=7
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -19,6 +19,7 @@ source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
musl-find_library.patch
fix-xattrs-glibc.patch
bpo-30353.patch
+ libressl.patch
"
builddir="$srcdir/Python-$pkgver"
diff --git a/main/python3/libressl.patch b/main/python3/libressl.patch
new file mode 100644
index 0000000000..21d9ed67d7
--- /dev/null
+++ b/main/python3/libressl.patch
@@ -0,0 +1,10 @@
+--- Python-3.6.3.orig/Lib/test/test_ssl.py
++++ Python-3.6.3/Lib/test/test_ssl.py
+@@ -3303,6 +3303,7 @@
+ self.assertIs(stats['client_npn_protocol'], None)
+
+ @unittest.skipUnless(ssl.HAS_NPN, "NPN support needed for this test")
++ @unittest.skipIf(IS_LIBRESSL, "LibreSSL doesn't support NPN anymore")
+ def test_npn_protocols(self):
+ server_protocols = ['http/1.1', 'spdy/2']
+ protocol_tests = [