aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-01 10:07:25 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-06-07 06:10:29 +0000
commit21c7909dd30ea71b0f605a7a08e62f00652f2269 (patch)
treec2460a86350c2c88a9a1b083d24bd8f77d62cb57 /main
parent38310f978752fb7a21539e596e169a739a56fe02 (diff)
downloadaports-21c7909dd30ea71b0f605a7a08e62f00652f2269.tar.bz2
aports-21c7909dd30ea71b0f605a7a08e62f00652f2269.tar.xz
main/linux-rpi: Adds the dwc2 kernel module for USB Gadget support
Partly implements #5629, USB2 and Gadget (guest) mode only.
Diffstat (limited to 'main')
-rw-r--r--main/linux-rpi/APKBUILD8
-rw-r--r--main/linux-rpi/config-rpi.armhf12
2 files changed, 15 insertions, 5 deletions
diff --git a/main/linux-rpi/APKBUILD b/main/linux-rpi/APKBUILD
index bb8fc29c47..2357adbba0 100644
--- a/main/linux-rpi/APKBUILD
+++ b/main/linux-rpi/APKBUILD
@@ -6,7 +6,7 @@ case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=${pkgver};;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with Raspberry Pi patches"
url=https://github.com/raspberrypi/linux
depends="mkinitfs linux-firmware"
@@ -202,7 +202,7 @@ f7142b2154dd5cfb5688ba692195ef6f rpi-cirrus-4.4.y-20160602.patch
b66e8aa4991ca5c2ccd61559ed7e6491 gpio-mcp23s08-pullups.patch
5508d2b3e5967bd57f92f551d90b3e54 rotary-encoder-fix.patch
29281b74d2cef6965fa4ab6d826a2aa4 issue-4973.patch
-6c2ffc255608414199dec2b7e452845e config-rpi.armhf
+a58b771ccb44b8ca3d742723652cfe5c config-rpi.armhf
92897d5e23fe720790866e939ae1ed71 config-rpi2.armhf
e587cae1dca2f5992555d9bcf53deecf markdt"
sha256sums="401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2 linux-4.4.tar.xz
@@ -212,7 +212,7 @@ f05f9cb93a6445b07231afd4ac1052ca572bf7441c7d5c073edc2c99a28af096 linux-4.4.y-rp
b389a556bbd98053881b43deef1adf20640f980557c5f37cfd7ece2daeecbda9 gpio-mcp23s08-pullups.patch
ab6740577fe8c1d71d2c716720ebbbf9a750985963d6938093b4ca9194b6e871 rotary-encoder-fix.patch
3a16e927ce53a8c56e7f1dd86fe8ad08b1c06466f5206c521a7e2de1e4796d6c issue-4973.patch
-caf8503b7a4301a2b2ffab137548e113c3d2e7e37fe447d4cdcbc357eafe896b config-rpi.armhf
+a27f0042e2bd4fda9ed08552b05c747c061ffec17268d58012e32364cd7c12eb config-rpi.armhf
f372f254bf021160d8091512c714f0ec0bb2cc46baf5c98d6270b15e9b725511 config-rpi2.armhf
0f6681fc5c3590e1dbe13a2bde796403bd1529cf0fe19720899eaa0db79bcb49 markdt"
sha512sums="13c8459933a8b80608e226a1398e3d1848352ace84bcfb7e6a4a33cb230bbe1ab719d4b58e067283df91ce5311be6d2d595fc8c19e2ae6ecc652499415614b3e linux-4.4.tar.xz
@@ -222,6 +222,6 @@ bb7bde9521281e5507bf0b0ed8912f56bd374df908f7f5f348a2faf223f3b92702988bdd07d0515a
36724ba56cb8fdf3a3d347cffb67ae1cc3d7b1052d526b6b5134ebf6baae9f9724b586c97833453dc7697ab24699426f0749af78b6a80be36967a80033a0cf40 gpio-mcp23s08-pullups.patch
3a711e2cdb6c0ecaceb3755437d38626dec8403e8aa167a6e16f64d8a8b7cc5bdc7e04aa7c05938719ebc90e319ec4124ee2151a7855e7838ee143b62d140ad0 rotary-encoder-fix.patch
501c91bf2538a18102da59bbccc3097f9c3c90079acc0e946ff075074160c09b8a66934e5ce5470e170f0e4f93d114709a95230367426d0bb7ea02c4bdf4cc9b issue-4973.patch
-03c5177d58cfdbf78824e90ed4026d0cd3efda0c7d695265b60992489484381018be5681ce84fa3aee3c7778e751647d6ec83b35c29cb2db2316b7a20b50e486 config-rpi.armhf
+53bd22f70985a53375e7cf6a2e1985fe058cde25680241560185cbc9c7ceb34687dd221f5978aed367e17b6dccc594bcd0cf79bf1f922d222cac8ff58f37e6e6 config-rpi.armhf
fb005473e6eec3d092688b3e5002a84fe2387250df0f4db7185b7f6aac40cced09302ad1ce6b6c4221a38e7b5904c2570a2f306bd1ccc29485c2f8d740c6299e config-rpi2.armhf
a4ecd1f48db64f9d6a189250d1937d7f2cd3a049a3d24cc527d04d05db06137722f1ba44bcd6033794781c3f2cfe2fbe065410a16de4bfdf4b1cd95d89322a77 markdt"
diff --git a/main/linux-rpi/config-rpi.armhf b/main/linux-rpi/config-rpi.armhf
index 5c10faa7ed..5f462718de 100644
--- a/main/linux-rpi/config-rpi.armhf
+++ b/main/linux-rpi/config-rpi.armhf
@@ -3393,7 +3393,16 @@ CONFIG_USBIP_HOST=m
# CONFIG_USBIP_DEBUG is not set
# CONFIG_USB_MUSB_HDRC is not set
# CONFIG_USB_DWC3 is not set
-# CONFIG_USB_DWC2 is not set
+CONFIG_USB_DWC2=m
+# CONFIG_USB_DWC2_HOST is not set
+
+#
+# Gadget/Dual-role mode requires USB Gadget support to be enabled
+#
+CONFIG_USB_DWC2_PERIPHERAL=y
+# CONFIG_USB_DWC2_DUAL_ROLE is not set
+# CONFIG_USB_DWC2_DEBUG is not set
+# CONFIG_USB_DWC2_TRACK_MISSED_SOFS is not set
# CONFIG_USB_CHIPIDEA is not set
# CONFIG_USB_ISP1760 is not set
@@ -4271,6 +4280,7 @@ CONFIG_IRQCHIP=y
# CONFIG_PHY_PXA_28NM_HSIC is not set
# CONFIG_PHY_PXA_28NM_USB2 is not set
# CONFIG_BCM_KONA_USB2_PHY is not set
+# CONFIG_PHY_SAMSUNG_USB2 is not set
# CONFIG_POWERCAP is not set
# CONFIG_MCB is not set