aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-31 09:12:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-31 09:16:22 +0000
commit2cda862cd3294bfc1a211a3ec468d8848358ca42 (patch)
tree782d79d641eaa20caafe4aab6728a3e5c85e1ee9 /main
parent4df7078acf29feca82b175bde6aa86cc5ca465cc (diff)
downloadaports-2cda862cd3294bfc1a211a3ec468d8848358ca42.tar.bz2
aports-2cda862cd3294bfc1a211a3ec468d8848358ca42.tar.xz
main/libfastjson: move from testing
fix pkgname-dbg typo remove redundant musl-dev makedepends
Diffstat (limited to 'main')
-rw-r--r--main/libfastjson/APKBUILD45
-rw-r--r--main/libfastjson/musl-fix.patch13
2 files changed, 58 insertions, 0 deletions
diff --git a/main/libfastjson/APKBUILD b/main/libfastjson/APKBUILD
new file mode 100644
index 0000000000..b1abb44873
--- /dev/null
+++ b/main/libfastjson/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Ashley Sommer <ashleysommer@gmail.com>
+# Maintainer: Ashley Sommer <ashleysommer@gmail.com>
+pkgname=libfastjson
+pkgver=0.99.2
+pkgrel=0
+pkgdesc="A fork of the json-c library for rsyslog, optimized for liblognorm processing."
+url="http://www.rsyslog.com/"
+arch="all"
+license="MIT"
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-dbg"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/rsyslog/$pkgname/archive/v$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ sh autogen.sh \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="72c71fcc8ca9f6d2fd84a42f27f21124 libfastjson-0.99.2.tar.gz"
+sha256sums="fcdca0c4702362de3db3f02c8da05f985b54a9eccd618af41730409b75d10a8f libfastjson-0.99.2.tar.gz"
+sha512sums="a62682886d36139c1cf9eb2454071d239cac66b076d94be90627f7062bb104102a19b231a5851586347d64c2065c2ba57bc115c6730e39ad78df61f22055635f libfastjson-0.99.2.tar.gz"
diff --git a/main/libfastjson/musl-fix.patch b/main/libfastjson/musl-fix.patch
new file mode 100644
index 0000000000..bfd20b56ef
--- /dev/null
+++ b/main/libfastjson/musl-fix.patch
@@ -0,0 +1,13 @@
+--- rsyslog-8.16.0/runtime/rsyslog.h
++++ rsyslog-8.16.0-musl/runtime/rsyslog.h
+@@ -643,3 +643,10 @@
+ #endif
+
+ #endif /* multi-include protection */
++
++/* musl patches for alpine */
++#define ACCESSPERMS (S_IRWXU|S_IRWXG|S_IRWXO)
++#define GLOB_BRACE 0
++#ifndef WAIT_ANY
++#define WAIT_ANY (-1)
++#endif