aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-03-16 07:37:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-16 07:37:21 +0000
commit2de96dffb016f6215562f5f413ea92db93e1700a (patch)
treee8d74b1bdebe288ea5ab50275fdf26c604b7725b /main
parent1cda56e4b2e8933e491e6bc7a87cb0f7e3d7f165 (diff)
downloadaports-2de96dffb016f6215562f5f413ea92db93e1700a.tar.bz2
aports-2de96dffb016f6215562f5f413ea92db93e1700a.tar.xz
main/rabbitmq-c: move from testing
needed by kamailio
Diffstat (limited to 'main')
-rw-r--r--main/rabbitmq-c/APKBUILD55
-rw-r--r--main/rabbitmq-c/musl-fix.patch11
2 files changed, 66 insertions, 0 deletions
diff --git a/main/rabbitmq-c/APKBUILD b/main/rabbitmq-c/APKBUILD
new file mode 100644
index 0000000000..12877f627d
--- /dev/null
+++ b/main/rabbitmq-c/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=rabbitmq-c
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="RabbitMQ C client"
+url="https://github.com/alanxz/rabbitmq-c"
+arch="all"
+license="MIT"
+depends_dev="libressl-dev popt-dev"
+makedepends="$depends_dev cmake xmlto doxygen"
+subpackages="$pkgname-utils $pkgname-doc $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/alanxz/$pkgname/archive/v$pkgver.tar.gz
+ musl-fix.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ mkdir -p build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ || return 1
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+utils() {
+ pkgdesc="$pkgdesc (command line utilities)"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+doc() {
+ pkgdesc="$pkgdesc (documentation and examples)"
+ arch="noarch"
+
+ mkdir -p "$subpkgdir"/usr/share/"$pkgname"
+ cp -a "$builddir"/build/docs "$builddir"/examples \
+ "$subpkgdir"/usr/share/"$pkgname"/
+}
+
+md5sums="51d5827651328236ecb7c60517c701c2 rabbitmq-c-0.8.0.tar.gz
+034d4367f68c0ff5a6f019c8c17279d7 musl-fix.patch"
+sha256sums="d8ed9dcb49903d83d79d7b227da35ef68c60e5e0b08d0fc1fb4e4dc577b8802b rabbitmq-c-0.8.0.tar.gz
+098ba5ad4fa5bb6f05d10ead47e1b6f8a39d5a9499c2c796a328f1d71a2f3042 musl-fix.patch"
+sha512sums="54e1c98a6b0eb7de848c9fac13dcde6455a6f71acee9e62a96c171f0e3e1cf860a70837f07b633d1a55b1ffd3d33ed7186b52495fa4c6e755b69a7e728eb9f1a rabbitmq-c-0.8.0.tar.gz
+da88bf18dc43800b1344f1274d5bafd99784119882593d13e3401bdd5c9bf52ac1a4af4af433ba1b9b0ae4627ffa08ce53486ec0f8a51593ed1e9db3dae54840 musl-fix.patch"
diff --git a/main/rabbitmq-c/musl-fix.patch b/main/rabbitmq-c/musl-fix.patch
new file mode 100644
index 0000000000..e76b082f92
--- /dev/null
+++ b/main/rabbitmq-c/musl-fix.patch
@@ -0,0 +1,11 @@
+--- ./librabbitmq/amqp_private.h.orig
++++ ./librabbitmq/amqp_private.h
+@@ -262,7 +262,7 @@
+ }
+
+ /* Determine byte order */
+-#if defined(__GLIBC__)
++#if defined(__linux__)
+ # include <endian.h>
+ # if (__BYTE_ORDER == __LITTLE_ENDIAN)
+ # define AMQP_LITTLE_ENDIAN