aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-04-01 08:05:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-04-01 10:20:09 +0200
commit2e87f1014a9d19c806698be3a43677d591faeb55 (patch)
treee15c3f11ae5ae632bede9e51cf4c14a59befb3f5 /main
parent9f05c49f1200e1d49bc9519599a3e665e68760c3 (diff)
downloadaports-2e87f1014a9d19c806698be3a43677d591faeb55.tar.bz2
aports-2e87f1014a9d19c806698be3a43677d591faeb55.tar.xz
main/uwsgi: use libucontext for ugreen plugin
Should fix the error: !!! UNABLE to load uWSGI plugin: Error relocating /usr/lib/uwsgi/ugreen_plugin.so: makecontext: symbol not found !!! (cherry picked from commit b72b900a069882fed03225151e6bc05a3ab75cbc)
Diffstat (limited to 'main')
-rw-r--r--main/uwsgi/APKBUILD7
-rw-r--r--main/uwsgi/musl-ucontext.patch12
2 files changed, 17 insertions, 2 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index 6c9daff296..db43bde70e 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uwsgi
pkgver=2.0.18
-pkgrel=6
+pkgrel=7
pkgdesc="uWSGI application container server"
url="http://projects.unbit.it/uwsgi/"
arch="all"
@@ -19,6 +19,7 @@ makedepends="
geoip-dev
jansson-dev
libcap-dev
+ libucontext-dev
linux-headers
linux-pam-dev
libxml2-dev
@@ -37,6 +38,7 @@ source="http://projects.unbit.it/downloads/uwsgi-$pkgver.tar.gz
readme.emperor
alpine.buildconf
musl-fix-python.patch
+ musl-ucontext.patch
"
options="!check"
@@ -216,4 +218,5 @@ sha512sums="6561703279bcc4a81311d033810ac066d0f113bab13b0942f3eef86cac29c584a664
370202e143d0e041a2e36905346080d3ca592c9a74705a8c4e142a1307d22b921c10e673d683ca284ea27d184474ed86edd7723a6e590d35a562ad7cf6afa529 uwsgi.ini
2798c9d2e49e29292ffe6a5a29b866301c78d5f322fc5d07dfa9569efdaa5220237a5f6744652fbdd957be29311ddaff190541333f042cbf0e907dfa98ce3e2a readme.emperor
f3cff00926929a5bb40afafb65fd5228582af35fbf524562282020c4c4ae9c659231b2381f4b3cceb18e8f3f6c888c21bdd8ed4ddcd81e92fbc6a0891800ce38 alpine.buildconf
-de68b16b44e554a79c073c9befa10566796316dbf4c375b4d6b633d80b0282694cca233f0a70f3d6570584324f14276826bbeb8f38b550c00087a05f9ba9227f musl-fix-python.patch"
+de68b16b44e554a79c073c9befa10566796316dbf4c375b4d6b633d80b0282694cca233f0a70f3d6570584324f14276826bbeb8f38b550c00087a05f9ba9227f musl-fix-python.patch
+d4b93e51619af5f8839cdc7279c69462947910df03104cfe6180d606403940fc60ad5dac66425ce8acbab67cc0c4f3e13126da0a329720cb03c67d447cd94ad9 musl-ucontext.patch"
diff --git a/main/uwsgi/musl-ucontext.patch b/main/uwsgi/musl-ucontext.patch
new file mode 100644
index 0000000000..94cac69baa
--- /dev/null
+++ b/main/uwsgi/musl-ucontext.patch
@@ -0,0 +1,12 @@
+diff --git a/plugins/ugreen/uwsgiplugin.py b/plugins/ugreen/uwsgiplugin.py
+index b206c62..9cdf209 100644
+--- a/plugins/ugreen/uwsgiplugin.py
++++ b/plugins/ugreen/uwsgiplugin.py
+@@ -2,6 +2,6 @@
+ NAME='ugreen'
+ CFLAGS = []
+ LDFLAGS = []
+-LIBS = []
++LIBS = ['-lucontext']
+
+ GCC_LIST = ['ugreen']