aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-13 09:18:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-13 15:40:02 +0000
commit2f69493d47a744f496684307ce6107557ea71bcb (patch)
tree8fa53aea3dd641912fa113c314ddc461c9a4c9a4 /main
parent3813c0af0c412ef9aa996ea6a832d9e40fa8477e (diff)
downloadaports-2f69493d47a744f496684307ce6107557ea71bcb.tar.bz2
aports-2f69493d47a744f496684307ce6107557ea71bcb.tar.xz
main/doxygen: upgrade to 1.8.18
Diffstat (limited to 'main')
-rw-r--r--main/doxygen/0001-issue-7464-1.8.17-test-suite-is-failing.patch80
-rw-r--r--main/doxygen/APKBUILD23
2 files changed, 9 insertions, 94 deletions
diff --git a/main/doxygen/0001-issue-7464-1.8.17-test-suite-is-failing.patch b/main/doxygen/0001-issue-7464-1.8.17-test-suite-is-failing.patch
deleted file mode 100644
index 9a895255bc..0000000000
--- a/main/doxygen/0001-issue-7464-1.8.17-test-suite-is-failing.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From cd9dee013dc749a10bbe019c350e0e62b6635795 Mon Sep 17 00:00:00 2001
-From: albert-github <albert.tests@gmail.com>
-Date: Wed, 1 Jan 2020 17:51:53 +0100
-Subject: [PATCH] issue #7464 1.8.17: test suite is failing
-
-On Windows the syntax with the command and arguments in one string worked but on *nix (and Cygwin) it didn't.
-- changed calls to Popen to split command (see also: https://docs.python.org/3/library/subprocess.html).
-- explicitly specify files to check for xhtml
-- changed call to xmllint for xhtml and docbook (due to stdout overflow in some cases, we are not really interested in the, formatted, output of xmllint).
-- in the update part a `read` was left, should have been removed.
----
- testing/runtests.py | 19 ++++++++++++-------
- 1 file changed, 12 insertions(+), 7 deletions(-)
-
-diff --git a/testing/runtests.py b/testing/runtests.py
-index a4118b86..10fe5021 100755
---- a/testing/runtests.py
-+++ b/testing/runtests.py
-@@ -3,6 +3,7 @@
- from __future__ import print_function
- import argparse, glob, itertools, re, shutil, os, sys
- import subprocess
-+import shlex
-
- config_reg = re.compile('.*\/\/\s*(?P<name>\S+):\s*(?P<value>.*)$')
-
-@@ -28,10 +29,10 @@ def xpopen(cmd, cmd1="",encoding='utf-8-sig', getStderr=False):
- return os.popen(cmd).read() # Python 2 without encoding
- else:
- if (getStderr):
-- proc = subprocess.run(cmd1,encoding=encoding,capture_output=True) # Python 3 with encoding
-- return proc.stderr
-+ proc = subprocess.Popen(shlex.split(cmd1),stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
-+ return proc.stderr.read()
- else:
-- proc = subprocess.Popen(cmd,stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
-+ proc = subprocess.Popen(shlex.split(cmd),stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
- return proc.stdout.read()
-
- class Tester:
-@@ -137,7 +138,7 @@ class Tester:
- print('GENERATE_DOCBOOK=NO', file=f)
- if (self.args.xhtml):
- print('GENERATE_HTML=YES', file=f)
-- # HTML_OUTPUT can also be set locally
-+ # HTML_OUTPUT can also have been set locally
- print('HTML_OUTPUT=%s/html' % self.test_out, file=f)
- print('HTML_FILE_EXTENSION=.xhtml', file=f)
- if (self.args.pdf):
-@@ -184,7 +185,7 @@ class Tester:
- print('Non-existing file %s after \'check:\' statement' % check_file)
- return
- # convert output to canonical form
-- data = xpopen('%s --format --noblanks --nowarning %s' % (self.args.xmllint,check_file)).read()
-+ data = xpopen('%s --format --noblanks --nowarning %s' % (self.args.xmllint,check_file))
- if data:
- # strip version
- data = re.sub(r'xsd" version="[0-9.-]+"','xsd" version=""',data).rstrip('\n')
-@@ -326,7 +327,7 @@ class Tester:
- tests.append(glob.glob('%s/*.xml' % (docbook_output)))
- tests.append(glob.glob('%s/*/*/*.xml' % (docbook_output)))
- tests = ' '.join(list(itertools.chain.from_iterable(tests))).replace(self.args.outputdir +'/','').replace('\\','/')
-- exe_string = '%s --nonet --postvalid %s' % (self.args.xmllint,tests)
-+ exe_string = '%s --noout --nonet --postvalid %s' % (self.args.xmllint,tests)
- exe_string1 = exe_string
- exe_string += ' %s' % (redirx)
- exe_string += ' %s more "%s/temp"' % (separ,docbook_output)
-@@ -346,7 +347,11 @@ class Tester:
- redirx=' 2> %s/temp >nul:'%html_output
- else:
- redirx='2>%s/temp >/dev/null'%html_output
-- exe_string = '%s --path dtd --nonet --postvalid %s/*xhtml' % (self.args.xmllint,html_output)
-+ check_file = []
-+ check_file.append(glob.glob('%s/*.xhtml' % (html_output)))
-+ check_file.append(glob.glob('%s/*/*/*.xhtml' % (html_output)))
-+ check_file = ' '.join(list(itertools.chain.from_iterable(check_file))).replace(self.args.outputdir +'/','').replace('\\','/')
-+ exe_string = '%s --noout --path dtd --nonet --postvalid %s' % (self.args.xmllint,check_file)
- exe_string1 = exe_string
- exe_string += ' %s' % (redirx)
- exe_string += ' %s more "%s/temp"' % (separ,html_output)
diff --git a/main/doxygen/APKBUILD b/main/doxygen/APKBUILD
index c02dc799f9..17f2d1cb15 100644
--- a/main/doxygen/APKBUILD
+++ b/main/doxygen/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=doxygen
-pkgver=1.8.17
-pkgrel=1
+pkgver=1.8.18
+pkgrel=0
pkgdesc="A documentation system for C++, C, Java, IDL and PHP"
url="http://www.doxygen.nl/"
arch="all"
@@ -10,31 +10,26 @@ checkdepends="libxml2-utils"
makedepends="flex bison coreutils perl python3 cmake"
source="http://doxygen.nl/files/doxygen-$pkgver.src.tar.gz
doxygen-1.8.14-install.patch
- 0001-issue-7464-1.8.17-test-suite-is-failing.patch
"
build() {
- cd "$builddir"
- cmake .\
+ cmake -B build \
-DGIT_EXECUTABLE=/bin/false \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=None \
- -Dbuild_xmlparser=ON
- make
+ -Dbuild_xmlparser=ON .
+ make -C build
}
check() {
- cd "$builddir"
# Remove test that use bibtex
rm -f ./testing/012_cite.dox
- make test
+ make -C build test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
-sha512sums="2fd087d127e301ea48355ea52c9af4f2091df06551cf64da80df81f0758194b296efb1e8d3962867a6a6d2da5a3fc323842f7766a445748005b30097ded30a75 doxygen-1.8.17.src.tar.gz
-a11ece43c640ffed707240f726b2005e103294e0351d7c3b6dd46ecc9bc0341b56c4bfb4e4daead3683129a1f332f283c578258aa1f611ec5a57c4da3bff8a21 doxygen-1.8.14-install.patch
-5b2dc0bc3dfa9b11c0ecf28e1d502f2c1112e67b47d191aa2cf294f74e41580881e02cf009c7de06dc75b0b0c0306d5c03eeca37b0f82c65e5a51cd68738e4c3 0001-issue-7464-1.8.17-test-suite-is-failing.patch"
+sha512sums="8a75b78db5b49c891342a40b452cae045aa4e317add12ba85a4759081dba5dab11f1a95a576df16d4f275c69a6e9ee1b8f8739c1bf8348f5b4578b1c41e2a32c doxygen-1.8.18.src.tar.gz
+a11ece43c640ffed707240f726b2005e103294e0351d7c3b6dd46ecc9bc0341b56c4bfb4e4daead3683129a1f332f283c578258aa1f611ec5a57c4da3bff8a21 doxygen-1.8.14-install.patch"