aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-04-10 10:06:27 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2019-04-10 10:06:27 +0200
commit40f6e52c56392ac77595c7388f055f61e29f814f (patch)
tree5b2818592c91dd36d09e7d0045134dc2259d7179 /main
parentac94a85a568f6fd5302de777d3614ed19d26ea07 (diff)
downloadaports-40f6e52c56392ac77595c7388f055f61e29f814f.tar.bz2
aports-40f6e52c56392ac77595c7388f055f61e29f814f.tar.xz
main/dtc: upgrade to 1.5.0
Patch is superseded by [0]. [0]: https://git.kernel.org/pub/scm/utils/dtc/dtc.git/commit/fdtdump.c?id=78e113e81c9d33d0f33704b187a46399d5a75419
Diffstat (limited to 'main')
-rw-r--r--main/dtc/APKBUILD6
-rw-r--r--main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch25
2 files changed, 2 insertions, 29 deletions
diff --git a/main/dtc/APKBUILD b/main/dtc/APKBUILD
index a6478a3946..375893db2e 100644
--- a/main/dtc/APKBUILD
+++ b/main/dtc/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dtc
-pkgver=1.4.7
+pkgver=1.5.0
pkgrel=0
pkgdesc="Device Tree Compiler"
url="http://devicetree.org/Device_Tree_Compiler"
@@ -12,7 +12,6 @@ makedepends="$depends_dev bison flex"
install=""
subpackages="$pkgname-dev libfdt"
source="https://kernel.org/pub/software/utils/dtc/dtc-$pkgver.tar.xz
- use-tx-as-the-type-specifier-instead-of-zx.patch
"
builddir="$srcdir/dtc-$pkgver"
@@ -37,5 +36,4 @@ libfdt() {
mv "$pkgdir"/usr/lib/libfdt* "$subpkgdir"/usr/lib/
}
-sha512sums="01e0c88aee154d8ce8a5b84a299c98d12df9698e5eff572409e5e912236028532309fd21ca6a146dffef859c665d476bbbe13c371c621c1dee4abe546e5e6ebf dtc-1.4.7.tar.xz
-6b03522fed030a6b2411bd12d1878667fec9ae9bcbfe60f7d5f82468bcbc2eab5956ae758086b8f2d5611e7a6584525ab33702df6f721b218ddb3205968da543 use-tx-as-the-type-specifier-instead-of-zx.patch"
+sha512sums="fd1e692a1b7bf7987f921ad17d9be6719f7b3aa7915873b45fa86f4ecb1398a0a62cdf53c1fddf98a0f7fed9bf34a79f684018bd01a2b5e88746b50879bf7102 dtc-1.5.0.tar.xz"
diff --git a/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch b/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch
deleted file mode 100644
index 3021c13954..0000000000
--- a/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 46ed9702a0005da87edd0cc3d34dbe24d1526784 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
-Date: Thu, 6 Jun 2013 17:01:39 +0200
-Subject: [PATCH] use tx as the type specifier instead of zx
-
-A couple of printf() commands use "zx" as a type specifier for printing
-a difference of 2 pointers. "z" means a size_t, but using "t" which is
-ptrdiff_t is correct. The issue was found on s390 (32-bit) where size_t
-is defined as "unsigned long" as opposed to the usual "unsigned int".
-
-Rebased-by: Breno Leitao <breno.leitao@gmail.com>
----
-diff --git a/fdtdump.c b/fdtdump.c
-index 4eaade9..4dcac19 100644
---- a/fdtdump.c
-+++ b/fdtdump.c
-@@ -98,7 +98,7 @@ static void dump_blob(void *blob, bool debug)
- p = p_struct;
- while ((tag = fdt32_to_cpu(GET_CELL(p))) != FDT_END) {
-
-- dumpf("%04zx: tag: 0x%08"PRIx32" (%s)\n",
-+ dumpf("%04tx: tag: 0x%08"PRIx32" (%s)\n",
- (uintptr_t)p - blob_off - 4, tag, tagname(tag));
-
- if (tag == FDT_BEGIN_NODE) {