aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-25 15:05:13 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-25 15:06:50 +0200
commit431e70edcbe28d57008805e5409f5aa9079e25d9 (patch)
tree5aae3b50690c98e3d0f21a0117cb37b19615c15d /main
parent0ffa818f20c2575490a2a80104e5d82dd2cc68cc (diff)
downloadaports-431e70edcbe28d57008805e5409f5aa9079e25d9.tar.bz2
aports-431e70edcbe28d57008805e5409f5aa9079e25d9.tar.xz
main/llvm4: disable check() on armhf
It takes tooo long to run them on the armhf builder.
Diffstat (limited to 'main')
-rw-r--r--main/llvm4/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/main/llvm4/APKBUILD b/main/llvm4/APKBUILD
index 0cb098c380..77d685c930 100644
--- a/main/llvm4/APKBUILD
+++ b/main/llvm4/APKBUILD
@@ -26,6 +26,12 @@ source="http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.xz
"
builddir="$srcdir/$_pkgname-$pkgver.src"
+# ARM has few failures in test suite that we don't care about currently and
+# also it takes forever to run them on the builder.
+case "$CARCH" in
+ arm*) options="!check";;
+esac
+
# NOTE: It seems that there's no (sane) way how to change includedir, sharedir
# etc. separately, just the CMAKE_INSTALL_PREFIX. Standard CMake variables and
# even LLVM-specific variables, that are related to these paths, actually
@@ -105,11 +111,7 @@ build() {
check() {
cd "$builddir"/build
- # ARM has few failures in test suite that we don't care about currently.
- case "$CARCH" in
- arm*) make check-llvm || true;;
- *) make check-llvm;;
- esac
+ make check-llvm
}
package() {