aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 14:33:17 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-12 15:05:26 +0000
commit4af82251577e3cb6261baf2e42c0673e91fa5248 (patch)
tree9847f9dde0d01cbdc998b81662694636e433748f /main
parent4f5a588a21508036340efb5258916a3537adc5d2 (diff)
downloadaports-4af82251577e3cb6261baf2e42c0673e91fa5248.tar.bz2
aports-4af82251577e3cb6261baf2e42c0673e91fa5248.tar.xz
main/sg3_utils: modernise, fix license, mark no tests
Diffstat (limited to 'main')
-rw-r--r--main/sg3_utils/APKBUILD25
1 files changed, 8 insertions, 17 deletions
diff --git a/main/sg3_utils/APKBUILD b/main/sg3_utils/APKBUILD
index ca30b78a61..a399463343 100644
--- a/main/sg3_utils/APKBUILD
+++ b/main/sg3_utils/APKBUILD
@@ -2,42 +2,33 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sg3_utils
pkgver=1.42
-pkgrel=0
+pkgrel=1
pkgdesc="Generic SCSI utilities"
url="http://sg.danny.cz/sg/sg3_utils.html"
arch="all"
-license="GPL"
+options="!check" # No test suite.
+license="BSD-3-Clause, GPL-2.0+"
depends=
makedepends="linux-headers"
install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://sg.danny.cz/sg/p/$pkgname-$pkgver.tgz"
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- # apply patches here
-}
-
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- || return 1
- make || return 1
+ --infodir=/usr/share/info
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="28080de5bf2222f8b55a29093bec8aea sg3_utils-1.42.tgz"
-sha256sums="1dcb7a0309bd0ba3d4a83acb526973b80106ee26cd9f7398186cd3f0633c9ef3 sg3_utils-1.42.tgz"
sha512sums="d16b65e36b2bccb4fc4c189f97e71fa38e6619f37d668a4ddd74a52c715fa62325288d9737812ed19c80547059dbd27be5a20565e27e1aabb571e8f5f8ac53ad sg3_utils-1.42.tgz"