aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-04 22:48:38 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-04 23:29:17 +0100
commit53b7f4b6d72d97926c97b54d3dad28155ee35e8f (patch)
tree26e11a22acdad4bf192d1001349ffc9a6133c7f4 /main
parentd3d12cb8342af9fb1601e7ded07bd6c90ebe6476 (diff)
downloadaports-53b7f4b6d72d97926c97b54d3dad28155ee35e8f.tar.bz2
aports-53b7f4b6d72d97926c97b54d3dad28155ee35e8f.tar.xz
main/pllua: upgrade to 1.1.0
Diffstat (limited to 'main')
-rw-r--r--main/pllua/9.3-headers.patch14
-rw-r--r--main/pllua/9.3-int2.patch13
-rw-r--r--main/pllua/9.3-notice-create-index.patch22
-rw-r--r--main/pllua/APKBUILD23
4 files changed, 8 insertions, 64 deletions
diff --git a/main/pllua/9.3-headers.patch b/main/pllua/9.3-headers.patch
deleted file mode 100644
index 859f2949c9..0000000000
--- a/main/pllua/9.3-headers.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/pllua.h b/pllua.h
-index 888307b..b6e7419 100644
---- a/pllua.h
-+++ b/pllua.h
-@@ -11,6 +11,9 @@
- #include <fmgr.h>
- #include <funcapi.h>
- #include <access/heapam.h>
-+#if PG_VERSION_NUM >= 90300
-+#include <access/htup_details.h>
-+#endif
- #include <catalog/namespace.h>
- #include <catalog/pg_proc.h>
- #include <catalog/pg_type.h>
diff --git a/main/pllua/9.3-int2.patch b/main/pllua/9.3-int2.patch
deleted file mode 100644
index 46b9782db9..0000000000
--- a/main/pllua/9.3-int2.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/plluaapi.c b/plluaapi.c
-index f24cd0c..3e3513d 100644
---- a/plluaapi.c
-+++ b/plluaapi.c
-@@ -38,7 +38,7 @@ typedef struct luaP_Info {
- /* extended type info */
- typedef struct luaP_Typeinfo {
- int oid;
-- int2 len;
-+ int16 len;
- char type;
- char align;
- bool byval;
diff --git a/main/pllua/9.3-notice-create-index.patch b/main/pllua/9.3-notice-create-index.patch
deleted file mode 100644
index d30b62437c..0000000000
--- a/main/pllua/9.3-notice-create-index.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/expected/plluatest.out
-+++ b/expected/plluatest.out
-@@ -232,8 +232,8 @@
- 1 | name | data
- (1 row)
-
-+SET client_min_messages = warning;
- CREATE TABLE tree (id INT PRIMARY KEY, lchild INT, rchild INT);
--NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "tree_pkey" for table "tree"
- CREATE FUNCTION filltree (t text, n int) RETURNS void AS $$
- local p = server.prepare("insert into " .. t .. " values($1, $2, $3)",
- {"int4", "int4", "int4"})
---- a/sql/plluatest.sql
-+++ b/sql/plluatest.sql
-@@ -160,6 +160,7 @@
- SELECT * FROM get_rows('name');
-
-
-+SET client_min_messages = warning;
- CREATE TABLE tree (id INT PRIMARY KEY, lchild INT, rchild INT);
-
- CREATE FUNCTION filltree (t text, n int) RETURNS void AS $$
diff --git a/main/pllua/APKBUILD b/main/pllua/APKBUILD
index 8722ce172f..0f73efdaed 100644
--- a/main/pllua/APKBUILD
+++ b/main/pllua/APKBUILD
@@ -1,33 +1,26 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=pllua
-pkgver=1.0
-pkgrel=1
+pkgver=1.1.0
+pkgrel=0
pkgdesc="Procedural language for PostgreSQL using Lua"
-url="http://pllua.projects.pgfoundry.org/"
+url="https://github.com/pllua/pllua"
arch="all"
license="GPL"
depends="postgresql"
makedepends="postgresql-dev lua-dev"
-source="http://pgfoundry.org/frs/download.php/3481/$pkgname-$pkgver.tar.gz
- 9.3-headers.patch
- 9.3-int2.patch
- 9.3-notice-create-index.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/pllua/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
-
+options="!check" # tests require running PostgreSQL
build() {
cd "$builddir"
- make
+ LUA_INCDIR=/usr/include LUALIB='-llua' USE_PGXS=1 make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make USE_PGXS=1 DESTDIR="$pkgdir" install
}
-sha512sums="99f007a39d5b7ac7f0c8bcdda1cb053b8a26b1d3f87006d8db61f73afeac29e0a9b054d398170a529cfc090e7083bb84098815fb67f2f6964b16297a47f5441b pllua-1.0.tar.gz
-de17345d216475d8524aa3ac58d4e66830326d8954529d6eb5c923d3038032af8975bfb66e34598e87bf6c27d49d341aed4b955e6a4f5054fc9699a9e7941308 9.3-headers.patch
-2066122be748ca0f99f6d8b62343412ead65329134f14040249dcc1389d01fa63e4bfbfff082a5ee1efff9e50d56a10b55629b961aa0b0e54a5ea6df0ccdc6e7 9.3-int2.patch
-fbeb59dbcb7667dc9b2ca7b513625db32bc51d5a40f5fc4ab081a633982a6433716c65dc2845c7647556c0eee660f32bfb3656c32dfd783e23cfcc97337f8eda 9.3-notice-create-index.patch"
+sha512sums="bd882a5782d72b24aaca81f6678eefae191bbf53b7e8152f3d83b1b89e49d6a1c9a17be5edbc7673ff6b4f48426cf3b4ee5c6b8349555ed55078fb1e7cc6829d pllua-1.1.0.tar.gz"